From patchwork Wed May 27 11:56:21 2020 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Dario Binacchi X-Patchwork-Id: 246677 List-Id: U-Boot discussion From: dariobin at libero.it (Dario Binacchi) Date: Wed, 27 May 2020 13:56:21 +0200 Subject: [PATCH v3 4/4] spl: fit: improve spl_nand_fit_read(...) readability In-Reply-To: <20200527115621.1062-1-dariobin@libero.it> References: <20200527115621.1062-1-dariobin@libero.it> Message-ID: <20200527115621.1062-5-dariobin@libero.it> Replacing the ret variable with err and handling first the error condition about the value returned by the spl_nand_fit_read routine, improves the code readability. Furthermore, the 'else' int the 'else return ret' instruction was useless. cc: Michael Trimarchi Signed-off-by: Dario Binacchi --- Changes in v3: None Changes in v2: None common/spl/spl_nand.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/common/spl/spl_nand.c b/common/spl/spl_nand.c index 1e6f2dce56..d13a524597 100644 --- a/common/spl/spl_nand.c +++ b/common/spl/spl_nand.c @@ -43,15 +43,15 @@ static ulong spl_nand_fit_read(struct spl_load_info *load, ulong offs, ulong size, void *dst) { ulong sector; - int ret; + int err; sector = *(int *)load->priv; offs = sector + nand_spl_adjust_offset(sector, offs - sector); - ret = nand_spl_load_image(offs, size, dst); - if (!ret) - return size; - else + err = nand_spl_load_image(offs, size, dst); + if (err) return 0; + + return size; } static int spl_nand_load_element(struct spl_image_info *spl_image,