Message ID | 20240621080554.18986-17-philmd@linaro.org |
---|---|
State | Superseded |
Headers | show |
Series | hw/sd/sdcard: Accumulation of cleanups and fixes | expand |
On 6/21/24 10:05 AM, Philippe Mathieu-Daudé wrote: > Extract sd_cmd_get_address() so we can re-use it > in various SDProto handlers. Use CARD_CAPACITY and > HWBLOCK_SHIFT definitions instead of magic values. > > Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org> Reviewed-by: Cédric Le Goater <clg@redhat.com> Thanks, C. > --- > hw/sd/sd.c | 10 +++++++++- > 1 file changed, 9 insertions(+), 1 deletion(-) > > diff --git a/hw/sd/sd.c b/hw/sd/sd.c > index cb9d85bb11..a0193a46ea 100644 > --- a/hw/sd/sd.c > +++ b/hw/sd/sd.c > @@ -579,6 +579,14 @@ static void sd_response_r7_make(SDState *sd, uint8_t *response) > stl_be_p(response, sd->vhs); > } > > +static uint64_t sd_req_get_address(SDState *sd, SDRequest req) > +{ > + if (FIELD_EX32(sd->ocr, OCR, CARD_CAPACITY)) { > + return (uint64_t) req.arg << HWBLOCK_SHIFT; > + } > + return req.arg; > +} > + > static inline uint64_t sd_addr_to_wpnum(uint64_t addr) > { > return addr >> (HWBLOCK_SHIFT + SECTOR_SHIFT + WPGROUP_SHIFT); > @@ -1103,7 +1111,7 @@ static sd_rsp_type_t sd_cmd_SET_BLOCK_COUNT(SDState *sd, SDRequest req) > static sd_rsp_type_t sd_normal_command(SDState *sd, SDRequest req) > { > uint16_t rca; > - uint64_t addr = (sd->ocr & (1 << 30)) ? (uint64_t) req.arg << 9 : req.arg; > + uint64_t addr = sd_req_get_address(sd, req); > > sd->last_cmd_name = sd_cmd_name(req.cmd); > /* CMD55 precedes an ACMD, so we are not interested in tracing it.
diff --git a/hw/sd/sd.c b/hw/sd/sd.c index cb9d85bb11..a0193a46ea 100644 --- a/hw/sd/sd.c +++ b/hw/sd/sd.c @@ -579,6 +579,14 @@ static void sd_response_r7_make(SDState *sd, uint8_t *response) stl_be_p(response, sd->vhs); } +static uint64_t sd_req_get_address(SDState *sd, SDRequest req) +{ + if (FIELD_EX32(sd->ocr, OCR, CARD_CAPACITY)) { + return (uint64_t) req.arg << HWBLOCK_SHIFT; + } + return req.arg; +} + static inline uint64_t sd_addr_to_wpnum(uint64_t addr) { return addr >> (HWBLOCK_SHIFT + SECTOR_SHIFT + WPGROUP_SHIFT); @@ -1103,7 +1111,7 @@ static sd_rsp_type_t sd_cmd_SET_BLOCK_COUNT(SDState *sd, SDRequest req) static sd_rsp_type_t sd_normal_command(SDState *sd, SDRequest req) { uint16_t rca; - uint64_t addr = (sd->ocr & (1 << 30)) ? (uint64_t) req.arg << 9 : req.arg; + uint64_t addr = sd_req_get_address(sd, req); sd->last_cmd_name = sd_cmd_name(req.cmd); /* CMD55 precedes an ACMD, so we are not interested in tracing it.
Extract sd_cmd_get_address() so we can re-use it in various SDProto handlers. Use CARD_CAPACITY and HWBLOCK_SHIFT definitions instead of magic values. Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org> --- hw/sd/sd.c | 10 +++++++++- 1 file changed, 9 insertions(+), 1 deletion(-)