mbox series

[v2,00/12] hw/sd/sdcard: Accumulation of cleanups and fixes

Message ID 20240625055354.23273-1-philmd@linaro.org
Headers show
Series hw/sd/sdcard: Accumulation of cleanups and fixes | expand

Message

Philippe Mathieu-Daudé June 25, 2024, 5:53 a.m. UTC
Since v1:
- various patches merged, few more added

Various SD card cleanups and fixes accumulated over
the years. Various have been useful to help integrating
eMMC support (which will come later).

Philippe Mathieu-Daudé (12):
  tests/qtest: Disable npcm7xx_sdhci tests using hardcoded RCA
  hw/sd/sdcard: Generate random RCA value
  hw/sd/sdcard: Track last command used to help logging
  hw/sd/sdcard: Trace block offset in READ/WRITE data accesses
  hw/sd/sdcard: Do not store vendor data on block drive (CMD56)
  hw/sd/sdcard: Send WRITE_PROT bits MSB first (CMD30)
  hw/sd/sdcard: Send NUM_WR_BLOCKS bits MSB first (ACMD22)
  hw/sd/sdcard: Use READY_FOR_DATA definition instead of magic value
  hw/sd/sdcard: Assign SDCardStates enum values
  hw/sd/sdcard: Simplify sd_inactive_state handling
  hw/sd/sdcard: Restrict SWITCH_FUNCTION to sd_transfer_state (CMD6)
  hw/sd/sdcard: Add direct reference to SDProto in SDState

 hw/sd/sd.c                       | 119 ++++++++++++++++---------------
 tests/qtest/npcm7xx_sdhci-test.c |   7 ++
 hw/sd/trace-events               |   4 +-
 3 files changed, 70 insertions(+), 60 deletions(-)

Comments

Cédric Le Goater June 25, 2024, 7:03 a.m. UTC | #1
On 6/25/24 7:53 AM, Philippe Mathieu-Daudé wrote:
> Since v1:
> - various patches merged, few more added
> 
> Various SD card cleanups and fixes accumulated over
> the years. Various have been useful to help integrating
> eMMC support (which will come later).
> 
> Philippe Mathieu-Daudé (12):
>    tests/qtest: Disable npcm7xx_sdhci tests using hardcoded RCA
>    hw/sd/sdcard: Generate random RCA value
>    hw/sd/sdcard: Track last command used to help logging
>    hw/sd/sdcard: Trace block offset in READ/WRITE data accesses
>    hw/sd/sdcard: Do not store vendor data on block drive (CMD56)
>    hw/sd/sdcard: Send WRITE_PROT bits MSB first (CMD30)
>    hw/sd/sdcard: Send NUM_WR_BLOCKS bits MSB first (ACMD22)
>    hw/sd/sdcard: Use READY_FOR_DATA definition instead of magic value
>    hw/sd/sdcard: Assign SDCardStates enum values
>    hw/sd/sdcard: Simplify sd_inactive_state handling
>    hw/sd/sdcard: Restrict SWITCH_FUNCTION to sd_transfer_state (CMD6)
>    hw/sd/sdcard: Add direct reference to SDProto in SDState
> 
>   hw/sd/sd.c                       | 119 ++++++++++++++++---------------
>   tests/qtest/npcm7xx_sdhci-test.c |   7 ++
>   hw/sd/trace-events               |   4 +-
>   3 files changed, 70 insertions(+), 60 deletions(-)
> 
Tested-by: Cédric Le Goater <clg@redhat.com>

Thanks,

C.