mbox series

[PATCH-for-5.2,v2,0/4] hw/usb/hcd-xhci: Fix USB_XHCI_NEC device

Message ID 20201109135300.2592982-1-philmd@redhat.com
Headers show
Series hw/usb/hcd-xhci: Fix USB_XHCI_NEC device | expand

Message

Philippe Mathieu-Daudé Nov. 9, 2020, 1:52 p.m. UTC
Fix a regression since xhci-sysbus introduction.

Since v1:
- Do not declare TYPE_XHCI abstract

Cleaned a bit code style while here, patches included for 6.0.

Supersedes: <20201107111307.262263-1-philmd@redhat.com>

Philippe Mathieu-Daudé (4):
  hw/usb/Kconfig: Fix USB_XHCI_NEC (depends on USB_XHCI_PCI)
  hw/usb/hcd-xhci: Restrict TYPE_XHCI to hw/usb/
  hw/usb/hcd-xhci-pci: Use OBJECT_DECLARE_SIMPLE_TYPE() macro
  hw/usb/hcd-xhci-pci: Rename "pci-xhci" as TYPE_XHCI_PCI_COMMON

 hw/usb/hcd-xhci-pci.h |  6 ++----
 hw/usb/hcd-xhci.h     |  1 +
 include/hw/usb/xhci.h |  1 -
 hw/usb/hcd-xhci-nec.c |  2 +-
 hw/usb/hcd-xhci-pci.c | 16 ++++++++--------
 hw/usb/Kconfig        |  4 +---
 6 files changed, 13 insertions(+), 17 deletions(-)

-- 
2.26.2

Comments

Richard Henderson Nov. 12, 2020, 9:22 p.m. UTC | #1
On 11/9/20 5:52 AM, Philippe Mathieu-Daudé wrote:
> Since commit 755fba11fbc and 8ddab8dd3d8 we can not build

> USB_XHCI_NEC without USB_XHCI_PCI. Correct the Kconfig

> dependency.

> 

> Fixes: 755fba11fbc ("usb/hcd-xhci: Move qemu-xhci device to hcd-xhci-pci.c")

> Reviewed-by: Sai Pavan Boddu <sai.pavan.boddu@xilinx.com>

> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>

> ---

>  hw/usb/Kconfig | 4 +---

>  1 file changed, 1 insertion(+), 3 deletions(-)


Reviewed-by: Richard Henderson <richard.henderson@linaro.org>


r~
Richard Henderson Nov. 12, 2020, 9:24 p.m. UTC | #2
On 11/9/20 5:53 AM, Philippe Mathieu-Daudé wrote:
> Follow the code base style by using the _COMMON suffix to

> abstract QOM types.

> 

> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>

> ---

>  hw/usb/hcd-xhci-pci.h |  4 ++--

>  hw/usb/hcd-xhci-nec.c |  2 +-

>  hw/usb/hcd-xhci-pci.c | 16 ++++++++--------

>  3 files changed, 11 insertions(+), 11 deletions(-)


Reviewed-by: Richard Henderson <richard.henderson@linaro.org>


r~