Message ID | 20180305160415.16760-11-andre.przywara@linaro.org |
---|---|
State | New |
Headers | show |
Series | New VGIC(-v2) implementation | expand |
Hi, On 05/03/18 16:03, Andre Przywara wrote: > gic_event_needs_delivery() is not named very intuitively, especially > the gic_ prefix is somewhat misleading. > Rename it to vgic_pending_irq(), which makes it clear that this relates > to the virtual GIC and is about interrupts. > > Signed-off-by: Andre Przywara <andre.przywara@linaro.org> > --- > Changelog RFC ... v1: > - new patch > > xen/arch/arm/gic-vgic.c | 2 +- > xen/include/asm-arm/event.h | 2 +- > xen/include/asm-arm/gic.h | 2 +- > 3 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/xen/arch/arm/gic-vgic.c b/xen/arch/arm/gic-vgic.c > index c0fe38fd37..60c6c463e9 100644 > --- a/xen/arch/arm/gic-vgic.c > +++ b/xen/arch/arm/gic-vgic.c > @@ -339,7 +339,7 @@ void gic_clear_pending_irqs(struct vcpu *v) > gic_remove_from_lr_pending(v, p); > } > > -int gic_events_need_delivery(void) > +int vgic_pending_irq(void) > { > struct vcpu *v = current; > struct pending_irq *p; > diff --git a/xen/include/asm-arm/event.h b/xen/include/asm-arm/event.h > index e8c2a6cb44..c4c79fa87d 100644 > --- a/xen/include/asm-arm/event.h > +++ b/xen/include/asm-arm/event.h > @@ -24,7 +24,7 @@ static inline int local_events_need_delivery_nomask(void) > * interrupts disabled so this shouldn't be a problem in the general > * case. > */ > - if ( gic_events_need_delivery() ) > + if ( vgic_pending_irq() ) I am not a big fan of this name either. I would much prefer to follow the suggestion I made in your RFC patch #26. By that I mean renaming the function vgic_vcpu_pending_irq and take a vCPU in parameter. For the old vGIC implementation, add an ASSERT(vcpu == current) to catch misuse for the function. Cheers,
diff --git a/xen/arch/arm/gic-vgic.c b/xen/arch/arm/gic-vgic.c index c0fe38fd37..60c6c463e9 100644 --- a/xen/arch/arm/gic-vgic.c +++ b/xen/arch/arm/gic-vgic.c @@ -339,7 +339,7 @@ void gic_clear_pending_irqs(struct vcpu *v) gic_remove_from_lr_pending(v, p); } -int gic_events_need_delivery(void) +int vgic_pending_irq(void) { struct vcpu *v = current; struct pending_irq *p; diff --git a/xen/include/asm-arm/event.h b/xen/include/asm-arm/event.h index e8c2a6cb44..c4c79fa87d 100644 --- a/xen/include/asm-arm/event.h +++ b/xen/include/asm-arm/event.h @@ -24,7 +24,7 @@ static inline int local_events_need_delivery_nomask(void) * interrupts disabled so this shouldn't be a problem in the general * case. */ - if ( gic_events_need_delivery() ) + if ( vgic_pending_irq() ) return 1; if ( !vcpu_info(current, evtchn_upcall_pending) ) diff --git a/xen/include/asm-arm/gic.h b/xen/include/asm-arm/gic.h index 3b2d0217a6..a23c307c3a 100644 --- a/xen/include/asm-arm/gic.h +++ b/xen/include/asm-arm/gic.h @@ -238,7 +238,7 @@ int gic_remove_irq_from_guest(struct domain *d, unsigned int virq, extern void vgic_sync_to_lrs(void); extern void gic_clear_pending_irqs(struct vcpu *v); -extern int gic_events_need_delivery(void); +extern int vgic_pending_irq(void); extern void init_maintenance_interrupt(void); extern void gic_raise_guest_irq(struct vcpu *v, unsigned int irq,
gic_event_needs_delivery() is not named very intuitively, especially the gic_ prefix is somewhat misleading. Rename it to vgic_pending_irq(), which makes it clear that this relates to the virtual GIC and is about interrupts. Signed-off-by: Andre Przywara <andre.przywara@linaro.org> --- Changelog RFC ... v1: - new patch xen/arch/arm/gic-vgic.c | 2 +- xen/include/asm-arm/event.h | 2 +- xen/include/asm-arm/gic.h | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-)