From patchwork Mon Nov 16 17:44:17 2015 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Felipe Balbi X-Patchwork-Id: 56666 Delivered-To: patch@linaro.org Received: by 10.112.155.196 with SMTP id vy4csp1455787lbb; Mon, 16 Nov 2015 09:45:13 -0800 (PST) X-Received: by 10.68.98.129 with SMTP id ei1mr55616244pbb.7.1447695913279; Mon, 16 Nov 2015 09:45:13 -0800 (PST) Return-Path: Received: from vger.kernel.org (vger.kernel.org. [209.132.180.67]) by mx.google.com with ESMTP id g7si40809549pat.185.2015.11.16.09.45.12; Mon, 16 Nov 2015 09:45:13 -0800 (PST) Received-SPF: pass (google.com: best guess record for domain of linux-kernel-owner@vger.kernel.org designates 209.132.180.67 as permitted sender) client-ip=209.132.180.67; Authentication-Results: mx.google.com; spf=pass (google.com: best guess record for domain of linux-kernel-owner@vger.kernel.org designates 209.132.180.67 as permitted sender) smtp.mailfrom=linux-kernel-owner@vger.kernel.org Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752932AbbKPRpL (ORCPT + 28 others); Mon, 16 Nov 2015 12:45:11 -0500 Received: from bear.ext.ti.com ([192.94.94.41]:37337 "EHLO bear.ext.ti.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752003AbbKPRpI (ORCPT ); Mon, 16 Nov 2015 12:45:08 -0500 Received: from dlelxv90.itg.ti.com ([172.17.2.17]) by bear.ext.ti.com (8.13.7/8.13.7) with ESMTP id tAGHiLPp021052; Mon, 16 Nov 2015 11:44:21 -0600 Received: from DFLE72.ent.ti.com (dfle72.ent.ti.com [128.247.5.109]) by dlelxv90.itg.ti.com (8.14.3/8.13.8) with ESMTP id tAGHiLkM001627; Mon, 16 Nov 2015 11:44:21 -0600 Received: from dflp32.itg.ti.com (10.64.6.15) by DFLE72.ent.ti.com (128.247.5.109) with Microsoft SMTP Server id 14.3.224.2; Mon, 16 Nov 2015 11:44:20 -0600 Received: from localhost (ileax41-snat.itg.ti.com [10.172.224.153]) by dflp32.itg.ti.com (8.14.3/8.13.8) with ESMTP id tAGHiJdU002899; Mon, 16 Nov 2015 11:44:20 -0600 From: Felipe Balbi To: Douglas Anderson , John Youn CC: Yunzhi Li , Heiko =?utf-8?Q?St=C3=BCbner?= , , Julius Werner , , , , Douglas Anderson , , , , Subject: Re: [PATCH v2 1/2] usb: dwc2: host: Fix missing device insertions In-Reply-To: <1446582629-30091-1-git-send-email-dianders@chromium.org> References: <1446582629-30091-1-git-send-email-dianders@chromium.org> User-Agent: Notmuch/0.21 (http://notmuchmail.org) Emacs/24.5.1 (x86_64-pc-linux-gnu) Date: Mon, 16 Nov 2015 11:44:17 -0600 Message-ID: <87y4dxltzi.fsf@saruman.tx.rr.com> MIME-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, (replying here for the context of why I think this is NOT the smallest patch possible for the -rc) Douglas Anderson writes: > If you've got your interrupt signals bouncing a bit as you insert your > USB device, you might end up in a state when the device is connected but > the driver doesn't know it. > > Specifically, the observed order is: > 1. hardware sees connect > 2. hardware sees disconnect > 3. hardware sees connect > 4. dwc2_port_intr() - clears connect interrupt > 5. dwc2_handle_common_intr() - calls dwc2_hcd_disconnect() > > Now you'll be stuck with the cable plugged in and no further interrupts > coming in but the driver will think we're disconnected. > > We'll fix this by checking for the missing connect interrupt and > re-connecting after the disconnect is posted. We don't skip the > disconnect because if there is a transitory disconnect we really want to > de-enumerate and re-enumerate. > > Signed-off-by: Douglas Anderson > --- > Changes in v2: > - Don't reconnect when called from _dwc2_hcd_stop() (John Youn) > > drivers/usb/dwc2/core.h | 6 ++++-- > drivers/usb/dwc2/core_intr.c | 4 ++-- > drivers/usb/dwc2/hcd.c | 40 ++++++++++++++++++++++++++++++++++++++-- > drivers/usb/dwc2/hcd_intr.c | 6 +----- > 4 files changed, 45 insertions(+), 11 deletions(-) > > diff --git a/drivers/usb/dwc2/core.h b/drivers/usb/dwc2/core.h > index a66d3cb62b65..daa1c342cdac 100644 > --- a/drivers/usb/dwc2/core.h > +++ b/drivers/usb/dwc2/core.h > @@ -1154,12 +1154,14 @@ static inline int dwc2_hsotg_set_test_mode(struct dwc2_hsotg *hsotg, > > #if IS_ENABLED(CONFIG_USB_DWC2_HOST) || IS_ENABLED(CONFIG_USB_DWC2_DUAL_ROLE) > extern int dwc2_hcd_get_frame_number(struct dwc2_hsotg *hsotg); > -extern void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg); > +extern void dwc2_hcd_connect(struct dwc2_hsotg *hsotg); > +extern void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg, bool force); this 'force' parameter is new and looks unnecessary for the -rc. > extern void dwc2_hcd_start(struct dwc2_hsotg *hsotg); > #else > static inline int dwc2_hcd_get_frame_number(struct dwc2_hsotg *hsotg) > { return 0; } > -static inline void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg) {} > +static inline void dwc2_hcd_connect(struct dwc2_hsotg *hsotg) {} > +static inline void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg, bool force) {} > static inline void dwc2_hcd_start(struct dwc2_hsotg *hsotg) {} > static inline void dwc2_hcd_remove(struct dwc2_hsotg *hsotg) {} > static inline int dwc2_hcd_init(struct dwc2_hsotg *hsotg, int irq) > diff --git a/drivers/usb/dwc2/core_intr.c b/drivers/usb/dwc2/core_intr.c > index 27daa42788b1..61601d16e233 100644 > --- a/drivers/usb/dwc2/core_intr.c > +++ b/drivers/usb/dwc2/core_intr.c > @@ -239,7 +239,7 @@ static void dwc2_handle_otg_intr(struct dwc2_hsotg *hsotg) > dev_dbg(hsotg->dev, "a_suspend->a_peripheral (%d)\n", > hsotg->op_state); > spin_unlock(&hsotg->lock); > - dwc2_hcd_disconnect(hsotg); > + dwc2_hcd_disconnect(hsotg, false); because force is unnecessary (it seems to be just an optimization to me), this change is unnecessary. > spin_lock(&hsotg->lock); > hsotg->op_state = OTG_STATE_A_PERIPHERAL; > } else { > @@ -401,7 +401,7 @@ static void dwc2_handle_disconnect_intr(struct dwc2_hsotg *hsotg) > dwc2_op_state_str(hsotg)); > > if (hsotg->op_state == OTG_STATE_A_HOST) > - dwc2_hcd_disconnect(hsotg); > + dwc2_hcd_disconnect(hsotg, false); and so is this. > dwc2_writel(GINTSTS_DISCONNINT, hsotg->regs + GINTSTS); > } > diff --git a/drivers/usb/dwc2/hcd.c b/drivers/usb/dwc2/hcd.c > index e79baf73c234..e208eac7ff57 100644 > --- a/drivers/usb/dwc2/hcd.c > +++ b/drivers/usb/dwc2/hcd.c > @@ -268,15 +268,33 @@ static void dwc2_hcd_cleanup_channels(struct dwc2_hsotg *hsotg) > } > > /** > + * dwc2_hcd_connect() - Handles connect of the HCD > + * > + * @hsotg: Pointer to struct dwc2_hsotg > + * > + * Must be called with interrupt disabled and spinlock held > + */ > +void dwc2_hcd_connect(struct dwc2_hsotg *hsotg) > +{ > + if (hsotg->lx_state != DWC2_L0) > + usb_hcd_resume_root_hub(hsotg->priv); > + > + hsotg->flags.b.port_connect_status_change = 1; > + hsotg->flags.b.port_connect_status = 1; > +} you make no mention of why this is needed. This is basically a refactor, not a fix. > +/** > * dwc2_hcd_disconnect() - Handles disconnect of the HCD > * > * @hsotg: Pointer to struct dwc2_hsotg > + * @force: If true, we won't try to reconnect even if we see device connected. > * > * Must be called with interrupt disabled and spinlock held > */ > -void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg) > +void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg, bool force) as mentioned before, unnecessary 'force' parameter. > @@ -315,6 +333,24 @@ void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg) > dwc2_hcd_cleanup_channels(hsotg); > > dwc2_host_disconnect(hsotg); > + > + /* > + * Add an extra check here to see if we're actually connected but > + * we don't have a detection interrupt pending. This can happen if: > + * 1. hardware sees connect > + * 2. hardware sees disconnect > + * 3. hardware sees connect > + * 4. dwc2_port_intr() - clears connect interrupt > + * 5. dwc2_handle_common_intr() - calls here > + * > + * Without the extra check here we will end calling disconnect > + * and won't get any future interrupts to handle the connect. > + */ > + if (!force) { > + hprt0 = dwc2_readl(hsotg->regs + HPRT0); > + if (!(hprt0 & HPRT0_CONNDET) && (hprt0 & HPRT0_CONNSTS)) > + dwc2_hcd_connect(hsotg); what's inside this 'force' branch is what you really need to fix the problem, right ? It seems like for the -rc cycle, all you need is: This has some code duplication and it'll *always* check for CONNDET | CONNSTS, but that's okay for the -rc. Follow-up patches (for v4.5 merge window) can refactor the code duplication and introduce 'force' parameter. > @@ -2365,7 +2401,7 @@ static void _dwc2_hcd_stop(struct usb_hcd *hcd) > > spin_lock_irqsave(&hsotg->lock, flags); > /* Ensure hcd is disconnected */ > - dwc2_hcd_disconnect(hsotg); > + dwc2_hcd_disconnect(hsotg, true); unnecessary change. > dwc2_hcd_stop(hsotg); > hsotg->lx_state = DWC2_L3; > hcd->state = HC_STATE_HALT; > diff --git a/drivers/usb/dwc2/hcd_intr.c b/drivers/usb/dwc2/hcd_intr.c > index bda0b21b850f..03504ac2fecc 100644 > --- a/drivers/usb/dwc2/hcd_intr.c > +++ b/drivers/usb/dwc2/hcd_intr.c > @@ -350,11 +350,7 @@ static void dwc2_port_intr(struct dwc2_hsotg *hsotg) > dev_vdbg(hsotg->dev, > "--Port Interrupt HPRT0=0x%08x Port Connect Detected--\n", > hprt0); > - if (hsotg->lx_state != DWC2_L0) > - usb_hcd_resume_root_hub(hsotg->priv); > - > - hsotg->flags.b.port_connect_status_change = 1; > - hsotg->flags.b.port_connect_status = 1; > + dwc2_hcd_connect(hsotg); unnecessary change. Do you agree or do you think 'force' is really necessary for this fix ? -- balbi diff --git a/drivers/usb/dwc2/hcd.c b/drivers/usb/dwc2/hcd.c index 571c21727ff9..967d1e686efe 100644 --- a/drivers/usb/dwc2/hcd.c +++ b/drivers/usb/dwc2/hcd.c @@ -276,6 +276,7 @@ static void dwc2_hcd_cleanup_channels(struct dwc2_hsotg *hsotg) */ void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg) { + u32 hprt0; u32 intr; /* Set status flags for the hub driver */ @@ -315,6 +316,15 @@ void dwc2_hcd_disconnect(struct dwc2_hsotg *hsotg) dwc2_hcd_cleanup_channels(hsotg); dwc2_host_disconnect(hsotg); + + hprt0 = dwc2_readl(hsotg->regs + HPRT0); + if (!(hprt0 & (HPRT0_CONNDET | HPRT0_CONNSTS))) { + if (hsotg->lx_state != DWC2_L0) + usb_hcd_resume_roothub(hsotg->priv); + + hsotg->flags.b.port_connect_status_change = 1; + hsotg->flags.b.port_connect_status = 1; + } } /**