mbox series

[v2,0/4] rtw88: four small code-cleanups and refactorings

Message ID 20230204233001.1511643-1-martin.blumenstingl@googlemail.com
Headers show
Series rtw88: four small code-cleanups and refactorings | expand

Message

Martin Blumenstingl Feb. 4, 2023, 11:29 p.m. UTC
Hello,

this series consists of four small patches which clean up and refactor
existing code in preparation for SDIO support. Functionality is
supposed to stay the same with these changes.

The goal of the first two patches is to make it easier to understand
the allowed values in the queue by using enum rtw_tx_queue_type instead
of u8.

The third patch in this series moves the rtw_tx_queue_type code out of
pci.c so it can be re-used by SDIO (and also USB) HCIs.

The last patch is another small cleanup to improve readability of the
code by using (already existing) macros instead of magic BIT(n).


Changes since v1 at [0]:
- add "wifi" to the subject of all patches
- add Ping-Ke's Acked-by to patches 2 and 4 (thank you!)
- add const keyword in patch 1
- add array bounds checking in patch 3
- remove references to another series from the cover letter as it's
  not needed as a precondition / dependency anymore


[0] https://lore.kernel.org/netdev/20220114234825.110502-1-martin.blumenstingl@googlemail.com/


Martin Blumenstingl (4):
  wifi: rtw88: pci: Use enum type for rtw_hw_queue_mapping() and
    ac_to_hwq
  wifi: rtw88: pci: Change queue datatype to enum rtw_tx_queue_type
  wifi: rtw88: Move enum rtw_tx_queue_type mapping code to tx.{c,h}
  wifi: rtw88: mac: Use existing macros in rtw_pwr_seq_parser()

 drivers/net/wireless/realtek/rtw88/mac.c |  4 +-
 drivers/net/wireless/realtek/rtw88/pci.c | 50 ++++++------------------
 drivers/net/wireless/realtek/rtw88/tx.c  | 41 +++++++++++++++++++
 drivers/net/wireless/realtek/rtw88/tx.h  |  3 ++
 4 files changed, 57 insertions(+), 41 deletions(-)

Comments

Simon Horman Feb. 5, 2023, 1:37 p.m. UTC | #1
On Sun, Feb 05, 2023 at 12:29:58AM +0100, Martin Blumenstingl wrote:
> rtw_hw_queue_mapping() and ac_to_hwq[] hold values of type enum
> rtw_tx_queue_type. Change their types to reflect this to make it easier
> to understand this part of the code.
> 
> While here, also change the array to be static const as it is not
> supposed to be modified at runtime.
> 
> Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>

Reviewed-by: Simon Horman <simon.horman@corigine.com>
Simon Horman Feb. 5, 2023, 1:37 p.m. UTC | #2
On Sun, Feb 05, 2023 at 12:29:59AM +0100, Martin Blumenstingl wrote:
> This makes it easier to understand which values are allowed for the
> "queue" variable when using the enum instead of an u8.
> 
> Acked-by: Ping-Ke Shih <pkshih@realtek.com>
> Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>

Reviewed-by: Simon Horman <simon.horman@corigine.com>