mbox series

[v1,0/5] Introduce a new helper marco DEFINE_STORE_ATTRIBUTE at seq_file.c

Message ID 1603355997-32350-1-git-send-email-luojiaxing@huawei.com
Headers show
Series Introduce a new helper marco DEFINE_STORE_ATTRIBUTE at seq_file.c | expand

Message

luojiaxing Oct. 22, 2020, 8:39 a.m. UTC
We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper marco for
read-write file too.

So we try to add this macro to help decrease code duplication.

Luo Jiaxing (5):
  seq_file: Introduce DEFINE_STORE_ATTRIBUTE() helper macro
  scsi: hisi_sas: Introduce DEFINE_STORE_ATTRIBUTE for debugfs
  scsi: qla2xxx: Introduce DEFINE_STORE_ATTRIBUTE for debugfs
  usb: dwc3: debugfs: Introduce DEFINE_STORE_ATTRIBUTE
  drm/i915/display: Introduce DEFINE_STORE_ATTRIBUTE for debugfs

 .../gpu/drm/i915/display/intel_display_debugfs.c   |  55 +--------
 drivers/scsi/hisi_sas/hisi_sas_main.c              | 135 +++------------------
 drivers/scsi/qla2xxx/qla_dfs.c                     |  19 +--
 drivers/usb/dwc3/debugfs.c                         |  52 +-------
 include/linux/seq_file.h                           |  15 +++
 5 files changed, 41 insertions(+), 235 deletions(-)

Comments

Al Viro Oct. 22, 2020, 12:28 p.m. UTC | #1
On Thu, Oct 22, 2020 at 04:39:52PM +0800, Luo Jiaxing wrote:
> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute

> for read-only file, but we found many of drivers also want a helper marco for

> read-write file too.


DEFINE_SHOW_ATTRIBUTE is a bloody bad idea; let's not replicate the garbage
any further.  If you want templates - C++ is over that way...
luojiaxing Oct. 23, 2020, 6:29 a.m. UTC | #2
Hi

On 2020/10/22 20:28, Al Viro wrote:
> On Thu, Oct 22, 2020 at 04:39:52PM +0800, Luo Jiaxing wrote:
>> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
>> for read-only file, but we found many of drivers also want a helper marco for
>> read-write file too.
> DEFINE_SHOW_ATTRIBUTE is a bloody bad idea; let's not replicate the garbage
> any further.  If you want templates - C++ is over that way...


I am sorry but would you mind to explain it in more detail that why 
DEFINE_SHOW_ATTRIBUTE is a bad idea?

I found that DEFINE_SHOW_ATTRIBUTE is convenient and avoids a lot of 
duplicate code When add some debugfs file for DFX.


Thanks

Jiaxing


>
> .
>