@@ -20,7 +20,7 @@ doxygen_install_dirs = []
doxygen_output = []
if get_option('doxygen-html')
doxygen_output += 'html'
- doxygen_install_dirs += get_option('datadir') / 'doc' / '@0@'.format(meson.project_name())
+ doxygen_install_dirs += docdir
endif
if get_option('doxygen-man')
doxygen_output += 'man'
@@ -306,6 +306,11 @@ if udevdir == ''
udevdir = '/lib/udev'
endif
+docdir = get_option('docdir')
+if docdir == ''
+ docdir = get_option('datadir') / 'doc' / '@0@'.format(meson.project_name())
+endif
+
qt_opengl_test = '''
#define GL_GLEXT_PROTOTYPES
#define QT_NO_OPENGL_ES_2
@@ -32,6 +32,8 @@ option('v4l2-ctl-stream-to', type : 'boolean',
description : 'Enable use of --stream-to in v4l2-ctl')
# Directories
+option('docdir', type : 'string',
+ description : 'Set documentation directory')
option('gconvsysdir', type : 'string',
description : 'Set system gconv directory (default is to autodetect)')
option('libv4l1subdir', type : 'string', value : 'libv4l',
This is needed by Gentoo Linux QA. Signed-off-by: James Le Cuirot <chewi@gentoo.org> --- doc/meson.build | 2 +- meson.build | 5 +++++ meson_options.txt | 2 ++ 3 files changed, 8 insertions(+), 1 deletion(-)