Message ID | 20210215181550.714101-5-zhengdejin5@gmail.com |
---|---|
State | Superseded |
Headers | show |
Series | [v1,1/4] PCI: Introduce pcim_alloc_irq_vectors() | expand |
Hi Dejin, > Use the correct name of device-managed function to alloc irq vectors, > the pcim_alloc_irq_vectors() function, a explicit device-managed version > of pci_alloc_irq_vectors(). [...] It would be "IRQ" in the sentence above. Perhaps the "Use the new function pcim_alloc_irq_vectors() to allocate IRQ vectors ..." would read a little better - generally, the above sentence could be improved. You might also want to add a more details about why to use this new function instead of the previous one, etc. Krzysztof
diff --git a/drivers/i2c/busses/i2c-thunderx-pcidrv.c b/drivers/i2c/busses/i2c-thunderx-pcidrv.c index 12c90aa0900e..63354e9fb726 100644 --- a/drivers/i2c/busses/i2c-thunderx-pcidrv.c +++ b/drivers/i2c/busses/i2c-thunderx-pcidrv.c @@ -192,7 +192,7 @@ static int thunder_i2c_probe_pci(struct pci_dev *pdev, i2c->hlc_int_enable = thunder_i2c_hlc_int_enable; i2c->hlc_int_disable = thunder_i2c_hlc_int_disable; - ret = pci_alloc_irq_vectors(pdev, 1, 1, PCI_IRQ_MSIX); + ret = pcim_alloc_irq_vectors(pdev, 1, 1, PCI_IRQ_MSIX); if (ret < 0) goto error;
Use the correct name of device-managed function to alloc irq vectors, the pcim_alloc_irq_vectors() function, a explicit device-managed version of pci_alloc_irq_vectors(). Signed-off-by: Dejin Zheng <zhengdejin5@gmail.com> --- drivers/i2c/busses/i2c-thunderx-pcidrv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)