From patchwork Wed Apr 20 22:16:40 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Linus Walleij X-Patchwork-Id: 66258 Delivered-To: patch@linaro.org Received: by 10.140.93.198 with SMTP id d64csp2703192qge; Wed, 20 Apr 2016 15:16:53 -0700 (PDT) X-Received: by 10.66.138.16 with SMTP id qm16mr15899157pab.28.1461190612988; Wed, 20 Apr 2016 15:16:52 -0700 (PDT) Return-Path: Received: from vger.kernel.org (vger.kernel.org. [209.132.180.67]) by mx.google.com with ESMTP id x127si7508390pfb.139.2016.04.20.15.16.52; Wed, 20 Apr 2016 15:16:52 -0700 (PDT) Received-SPF: pass (google.com: best guess record for domain of linux-gpio-owner@vger.kernel.org designates 209.132.180.67 as permitted sender) client-ip=209.132.180.67; Authentication-Results: mx.google.com; dkim=neutral (body hash did not verify) header.i=@linaro.org; spf=pass (google.com: best guess record for domain of linux-gpio-owner@vger.kernel.org designates 209.132.180.67 as permitted sender) smtp.mailfrom=linux-gpio-owner@vger.kernel.org; dmarc=fail (p=NONE dis=NONE) header.from=linaro.org Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751369AbcDTWQv (ORCPT + 4 others); Wed, 20 Apr 2016 18:16:51 -0400 Received: from mail-lf0-f42.google.com ([209.85.215.42]:33821 "EHLO mail-lf0-f42.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751002AbcDTWQu (ORCPT ); Wed, 20 Apr 2016 18:16:50 -0400 Received: by mail-lf0-f42.google.com with SMTP id j11so49659255lfb.1 for ; Wed, 20 Apr 2016 15:16:49 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=linaro.org; s=google; h=from:to:cc:subject:date:message-id; bh=igPIo5NmH54Mly2LuYbfvFXw0Wh7qJgQ99ZTeIJn97Y=; b=XSRODxg3ttZX+Gxml9LxhuUeSBJftMSNuKFNNZKLFHtrsYznOHbpj+RtF0ZYb+1knS zttQwyuwggY8sjGncUvTbfy+HvcmoXsA/bqLFTCkKffuQ+8GVrbx2wG/KIR1KbZhBQnw T9U/abG4UT2sSa/Amp5EFAkQ7VGPqOnNE4hN8= X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:from:to:cc:subject:date:message-id; bh=igPIo5NmH54Mly2LuYbfvFXw0Wh7qJgQ99ZTeIJn97Y=; b=ANTHcW7m8ouqIVSGBAzg0plL9Ynig9K8haXSALw+EpF3In98yLoxOZNsAcqEzI04iP 6CvBJgvVK4Vq1y+b4KxQ6WoH+tPxf/TDM40bdRTwOSmIbDyAco77zj/UGPSx7ONKo5En rDEsP3N38s+Y/skIZyEeikJEmzAlncHcM2V8AY9Uh02dx449yle3DrnmgRYG+0NS7IcA 4S3oEAwoj3NMh3Wptf4PnIXOJj28zu09see65pbuqrlAUiE9XoUYPsxfZFWK1j/0HB/E dMmpnOHd3zjB67FHd54iJyw3gdI5IKK5VYUDOxqNq3IiBZ/bxS86/S+9y5QJHeQdpSkF C7AA== X-Gm-Message-State: AOPr4FUSnOY3AAruX4+/gd/T8n6Ufw8Rtyrz5T2tA9gdKT11sMCO0OWV6X5CzCpBeXLW4S/d X-Received: by 10.25.23.233 with SMTP id 102mr4782865lfx.113.1461190608455; Wed, 20 Apr 2016 15:16:48 -0700 (PDT) Received: from localhost.localdomain.localdomain (c-927b71d5.014-348-6c756e10.cust.bredbandsbolaget.se. [213.113.123.146]) by smtp.gmail.com with ESMTPSA id mt4sm1458860lbc.31.2016.04.20.15.16.46 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Wed, 20 Apr 2016 15:16:46 -0700 (PDT) From: Linus Walleij To: linux-gpio@vger.kernel.org, Alexandre Courbot , Johan Hovold , Michael Welling , Markus Pargmann , Arnd Bergmann Cc: Bamvor Jian Zhang , Grant Likely , Linus Walleij , Rob Herring , devicetree@vger.kernel.org Subject: [PATCH v2] gpio: of: make it possible to name GPIO lines Date: Thu, 21 Apr 2016 00:16:40 +0200 Message-Id: <1461190600-20955-1-git-send-email-linus.walleij@linaro.org> X-Mailer: git-send-email 2.4.11 Sender: linux-gpio-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-gpio@vger.kernel.org Make it possible to name the producer side of a GPIO line using a "gpio-names" property array, modeled on the "clock-names" property from the clock bindings. This naming is especially useful for: - Debugging: lines are named after function, not just opaque offset numbers. - Exploration: systems where some or all GPIO lines are available to end users, such as prototyping, one-off's "makerspace usecases" users are helped by the names of the GPIO lines when tinkering. This usecase has been surfacing recently. The gpio-names attribute is completely optional. Cc: Rob Herring Cc: Grant Likely Cc: devicetree@vger.kernel.org Signed-off-by: Linus Walleij --- ChangeLog v1->v2: - Make the naming function return void: we continue at all times and always return 0 anyway. - Fix a return value check. This has been discussed at some length now. Why we are not using hogs: these are consumer side, not producer side. The gpio-controller in DT (gpio_chip in Linux) is a producer, not a consumer. This patch is not about assigning initial values to GPIO lines. That is an orthogonal usecase. This is just about naming lines. --- Documentation/devicetree/bindings/gpio/gpio.txt | 19 +++++++++++++ drivers/gpio/gpiolib-of.c | 38 +++++++++++++++++++++++++ 2 files changed, 57 insertions(+) -- 2.4.11 -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt b/Documentation/devicetree/bindings/gpio/gpio.txt index c88d2ccb05ca..6b371ab6098e 100644 --- a/Documentation/devicetree/bindings/gpio/gpio.txt +++ b/Documentation/devicetree/bindings/gpio/gpio.txt @@ -152,6 +152,21 @@ additional bitmask is needed to specify which GPIOs are actually in use, and which are dummies. The bindings for this case has not yet been specified, but should be specified if/when such hardware appears. +Optionally, a GPIO controller may have a "gpio-names" property. This is +an array of strings defining the names of the GPIO lines going out of the +GPIO controller. This name should be the most meaningful producer name +for the system, such as a rail name indicating the usage. Package names +such as pin name are discouraged: such lines have opaque names (since they +are by definition generic purpose) and such names are usually not very +helpful. For example "MMC-CD", "Red LED Vdd" and "ethernet reset" are +reasonable line names as they describe what the line is used for. "GPIO0" +is not a good name to give to a GPIO line. Placeholders are discouraged: +rather use the "" (blank string) if the use of the GPIO line is undefined +in your design. The names are assigned starting from line offset 0 from +left to right from the passed array. An incomplete array (where the number +of passed named are less than ngpios) will still be used up until the last +provided valid line index. + Example: gpio-controller@00000000 { @@ -160,6 +175,10 @@ gpio-controller@00000000 { gpio-controller; #gpio-cells = <2>; ngpios = <18>; + gpio-names = "MMC-CD", "MMC-WP", "VDD eth", "RST eth", "LED R", + "LED G", "LED B", "Col A", "Col B", "Col C", "Col D", + "Row A", "Row B", "Row C", "Row D", "NMI button", + "poweroff", "reset"; } The GPIO chip may contain GPIO hog definitions. GPIO hogging is a mechanism diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c index d81dbd8e90d9..430159df5d73 100644 --- a/drivers/gpio/gpiolib-of.c +++ b/drivers/gpio/gpiolib-of.c @@ -196,6 +196,40 @@ static struct gpio_desc *of_parse_own_gpio(struct device_node *np, } /** + * of_gpiochip_set_names() - set up the names of the lines + * @chip: GPIO chip whose lines should be named, if possible + */ +static void of_gpiochip_set_names(struct gpio_chip *gc) +{ + struct gpio_device *gdev = gc->gpiodev; + struct device_node *np = gc->of_node; + int i; + int nstrings; + + /* Do we even have the "gpio-names" property */ + if (!of_property_read_bool(np, "gpio-names")) + return; + + nstrings = of_property_count_strings(np, "gpio-names"); + for (i = 0; i < nstrings; i++) { + const char *name; + int ret; + + ret = of_property_read_string_index(np, + "gpio-names", + i, + &name); + if (!ret) + gdev->descs[i].name = name; + + /* Empty strings are OK */ + if (ret < 0 && ret != -ENODATA) + dev_err(&gdev->dev, "unable to name line %d\n", + i); + } +} + +/** * of_gpiochip_scan_gpios - Scan gpio-controller for gpio definitions * @chip: gpio chip to act on * @@ -445,6 +479,10 @@ int of_gpiochip_add(struct gpio_chip *chip) if (status) return status; + /* If the chip defines names itself, these take precedence */ + if (!chip->names) + of_gpiochip_set_names(chip); + of_node_get(chip->of_node); return of_gpiochip_scan_gpios(chip);