Message ID | cover.1746662899.git.Jonathan.Santos@analog.com |
---|---|
Headers | show |
Series | iio: adc: ad7768-1: Add features, improvements, and fixes | expand |
On Thu, May 08, 2025 at 02:03:30PM -0300, Jonathan Santos wrote: > In addition to GPIO synchronization, The AD7768-1 also supports > synchronization over SPI, which use is recommended when the GPIO > cannot provide a pulse synchronous with the base MCLK signal. It > consists of looping back the SYNC_OUT to the SYNC_IN pin and send > a command via SPI to trigger the synchronization. > > Introduce the 'trigger-sources' property to enable SPI-based > synchronization via SYNC_OUT pin, along with additional optional > entries for GPIO3 and DRDY pins. > > Also create #trigger-source-cells property to differentiate the trigger > sources provided by the ADC. To improve readability, create a > adi,ad7768-1.h header with the macros for the cell values. > > While at it, add description to the interrupts property. > > Reviewed-by: David Lechner <dlechner@baylirbe.com> > Signed-off-by: Jonathan Santos <Jonathan.Santos@analog.com> Acked-by: Conor Dooley <conor.dooley@microchip.com>
On Thu, May 08, 2025 at 02:03:30PM -0300, Jonathan Santos wrote: > +dependencies: > + adi,sync-in-gpios: > + not: > + required: > + - trigger-sources > + trigger-sources: > + not: > + required: > + - adi,sync-in-gpios Actually, this is normally not written like this. Usually it is done as an allOf entry: - if: required: - maxim,gpio-poc then: properties: poc-supply: false gpio-controller: false
On Fri, May 09, 2025 at 05:18:55PM +0100, Conor Dooley wrote: > On Thu, May 08, 2025 at 02:03:30PM -0300, Jonathan Santos wrote: > > +dependencies: > > + adi,sync-in-gpios: > > + not: > > + required: > > + - trigger-sources > > + trigger-sources: > > + not: > > + required: > > + - adi,sync-in-gpios > > Actually, this is normally not written like this. Usually it is done as > an allOf entry: > - if: > required: > - maxim,gpio-poc > then: > properties: > poc-supply: false > gpio-controller: false Using 'dependencies' is fine here. It's actually shorter. Rob