Message ID | 20210509214307.4610-2-bvanassche@acm.org |
---|---|
State | New |
Headers | show |
Series | Rename scsi_get_lba() into scsi_get_pos() | expand |
diff --git a/include/scsi/scsi_cmnd.h b/include/scsi/scsi_cmnd.h index adb8df40b942..8147b1c0f265 100644 --- a/include/scsi/scsi_cmnd.h +++ b/include/scsi/scsi_cmnd.h @@ -290,6 +290,11 @@ static inline sector_t scsi_get_lba(struct scsi_cmnd *scmd) return blk_rq_pos(scmd->request); } +static inline sector_t scsi_get_pos(struct scsi_cmnd *scmd) +{ + return blk_rq_pos(scmd->request); +} + static inline unsigned int scsi_prot_interval(struct scsi_cmnd *scmd) { return scmd->device->sector_size;
Since scsi_get_lba() returns a sector_t value instead of the LBA, the name of that function is confusing. Introduce an identical function scsi_get_pos(). A later patch will remove scsi_get_lba(). Signed-off-by: Bart Van Assche <bvanassche@acm.org> --- include/scsi/scsi_cmnd.h | 5 +++++ 1 file changed, 5 insertions(+)