Message ID | 20210509214307.4610-4-bvanassche@acm.org |
---|---|
State | Superseded |
Headers | show |
Series | Rename scsi_get_lba() into scsi_get_pos() | expand |
diff --git a/drivers/s390/scsi/zfcp_fsf.c b/drivers/s390/scsi/zfcp_fsf.c index 2e4804ef2fb9..ae308ef06714 100644 --- a/drivers/s390/scsi/zfcp_fsf.c +++ b/drivers/s390/scsi/zfcp_fsf.c @@ -2600,7 +2600,7 @@ int zfcp_fsf_fcp_cmnd(struct scsi_cmnd *scsi_cmnd) if (scsi_get_prot_op(scsi_cmnd) != SCSI_PROT_NORMAL) { io->data_block_length = scsi_cmnd->device->sector_size; - io->ref_tag_value = scsi_get_lba(scsi_cmnd) & 0xFFFFFFFF; + io->ref_tag_value = lower_32_bits(scsi_get_pos(scsi_cmnd)); } if (zfcp_fsf_set_data_dir(scsi_cmnd, &io->data_direction))
Use scsi_get_pos() instead of scsi_get_lba() since the name of the latter is confusing. Additionally, use lower_32_bits() instead of open-coding it. This patch does not change any functionality. Cc: Benjamin Block <bblock@linux.ibm.com> Signed-off-by: Bart Van Assche <bvanassche@acm.org> --- drivers/s390/scsi/zfcp_fsf.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)