Message ID | 20201015184416.38999-3-andriy.shevchenko@linux.intel.com |
---|---|
State | New |
Headers | show |
Series | [v2,1/3] lib/list_kunit: Follow new file name convention for KUnit tests | expand |
On Fri, Oct 16, 2020 at 2:44 AM Andy Shevchenko <andriy.shevchenko@linux.intel.com> wrote: > > Follow new file name convention for the KUnit tests. > Since we have lib/*test*.c in a few variations, > use 'kunit' suffix to distinguish usual test cases > with KUnit-based ones. > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Again, this worked and looks good to me. Apart from noting that the module name will change (so if people are depending on that, it'll break things), I'm all in favour of this. For the record (since it's not quite upstream yet), the naming documentation referenced is currently available here: https://git.kernel.org/pub/scm/linux/kernel/git/shuah/linux-kselftest.git/tree/Documentation/dev-tools/kunit/style.rst?h=kunit Anyway, Reviewed-by: David Gow <davidgow@google.com> Thanks, -- David
diff --git a/lib/Makefile b/lib/Makefile index 5c18519d6733..70a4a21ff5d6 100644 --- a/lib/Makefile +++ b/lib/Makefile @@ -350,6 +350,6 @@ obj-$(CONFIG_PLDMFW) += pldmfw/ # KUnit tests obj-$(CONFIG_BITFIELD_KUNIT) += bitfield_kunit.o +obj-$(CONFIG_BITS_TEST) += bits_kunit.o obj-$(CONFIG_LINEAR_RANGES_TEST) += linear_ranges_kunit.o obj-$(CONFIG_LIST_KUNIT_TEST) += list_kunit.o -obj-$(CONFIG_BITS_TEST) += test_bits.o diff --git a/lib/test_bits.c b/lib/bits_kunit.c similarity index 100% rename from lib/test_bits.c rename to lib/bits_kunit.c
Follow new file name convention for the KUnit tests. Since we have lib/*test*.c in a few variations, use 'kunit' suffix to distinguish usual test cases with KUnit-based ones. Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> --- v2: new patch lib/Makefile | 2 +- lib/{test_bits.c => bits_kunit.c} | 0 2 files changed, 1 insertion(+), 1 deletion(-) rename lib/{test_bits.c => bits_kunit.c} (100%)