@@ -60,9 +60,9 @@ CFLAGS_test_bitops.o += -Werror
obj-$(CONFIG_TEST_SYSCTL) += test_sysctl.o
obj-$(CONFIG_TEST_HASH) += test_hash.o test_siphash.o
obj-$(CONFIG_TEST_IDA) += test_ida.o
-obj-$(CONFIG_KASAN_KUNIT_TEST) += test_kasan.o
-CFLAGS_test_kasan.o += -fno-builtin
-CFLAGS_test_kasan.o += $(call cc-disable-warning, vla)
+obj-$(CONFIG_KASAN_KUNIT_TEST) += kasan_kunit.o
+CFLAGS_kasan_kunit.o += -fno-builtin
+CFLAGS_kasan_kunit.o += $(call cc-disable-warning, vla)
obj-$(CONFIG_TEST_KASAN_MODULE) += test_kasan_module.o
obj-$(CONFIG_TEST_UBSAN) += test_ubsan.o
CFLAGS_test_ubsan.o += $(call cc-disable-warning, vla)
similarity index 100%
rename from lib/test_kasan.c
rename to lib/kasan_kunit.c
The proposed KUnit test naming guidelines[1] suggest naming KUnit test modules [suite]_kunit (and hence test source files [suite]_kunit.c). Rename test_kunit.c to kasan_kunit.c to comply with this, and be consistent with other KUnit tests. [1]: https://lore.kernel.org/linux-kselftest/20200702071416.1780522-1-davidgow@google.com/ Signed-off-by: David Gow <davidgow@google.com> --- lib/Makefile | 6 +++--- lib/{test_kasan.c => kasan_kunit.c} | 0 2 files changed, 3 insertions(+), 3 deletions(-) rename lib/{test_kasan.c => kasan_kunit.c} (100%)