Message ID | 20240226141108.73664-1-philmd@linaro.org |
---|---|
Headers | show |
Series | string list functions | expand |
Thanks for trying a V6 Philippe. I'll take it from here. It helps to know that someone besides me thinks these functions are worth having. - Steve On 2/26/2024 9:11 AM, Philippe Mathieu-Daudé wrote: > Hi Markus, > > Here are the patches I queued until you told me you'd > object to the CamelCase filename strList.[ch]. > > Steve, please take over ;) > > Since v5: > - Cover files in MAINTAINERS > - Complete @docstring mentioning g_auto. > > v5: https://lore.kernel.org/qemu-devel/1708638470-114846-3-git-send-email-steven.sistare@oracle.com/ > > Steve Sistare (5): > util: str_split > qapi: QAPI_LIST_LENGTH > util: strv_from_strList > util: strList unit tests > migration: simplify exec migration functions > > MAINTAINERS | 2 + > include/monitor/hmp.h | 1 - > include/qapi/util.h | 13 +++++++ > include/qemu/strList.h | 33 ++++++++++++++++ > migration/exec.c | 57 ++++------------------------ > monitor/hmp-cmds.c | 19 ---------- > net/net-hmp-cmds.c | 3 +- > stats/stats-hmp-cmds.c | 3 +- > tests/unit/test-strList.c | 80 +++++++++++++++++++++++++++++++++++++++ > util/strList.c | 38 +++++++++++++++++++ > tests/unit/meson.build | 1 + > util/meson.build | 1 + > 12 files changed, 180 insertions(+), 71 deletions(-) > create mode 100644 include/qemu/strList.h > create mode 100644 tests/unit/test-strList.c > create mode 100644 util/strList.c >
Philippe Mathieu-Daudé <philmd@linaro.org> writes: > Hi Markus, > > Here are the patches I queued until you told me you'd > object to the CamelCase filename strList.[ch]. > > Steve, please take over ;) I'm going to post the part of the series I'm ready to queue as v7, with minor modifications: * Rename strv_from_strList() to strv_from_str_list(), and put it into qapi/qapi-type-helpers.c. * Tweak its function comment. * Rename its local variable @argv to @strv. * Cosmetic commit message tweaks. We can then talk about the remainder.
On 2/27/2024 10:28 AM, Markus Armbruster wrote: > Philippe Mathieu-Daudé <philmd@linaro.org> writes: > >> Hi Markus, >> >> Here are the patches I queued until you told me you'd >> object to the CamelCase filename strList.[ch]. >> >> Steve, please take over ;) > > I'm going to post the part of the series I'm ready to queue as v7, with > minor modifications: > > * Rename strv_from_strList() to strv_from_str_list(), and put it into > qapi/qapi-type-helpers.c. > > * Tweak its function comment. > > * Rename its local variable @argv to @strv. > > * Cosmetic commit message tweaks. > > We can then talk about the remainder. Thanks Markus, that saves some time and email. - Steve