Message ID | 20220609200709.4455-1-wsa+renesas@sang-engineering.com |
---|---|
State | Superseded |
Headers | show |
Series | [v2] thermal: rcar_gen3_thermal: improve logging during probe | expand |
Hi Wolfram, On Fri, Jun 10, 2022 at 3:13 PM Wolfram Sang <wsa+renesas@sang-engineering.com> wrote: > > Bikeshedding, I'm not keen on this style as it makes it harder IMHO to > > grep for log strings in the code. But I don't dislike it enough to ask > > you to change it ;-) So if you and Geert are happy with this style, > > Seems reasonable to me, Geert what do you think? I plead guilty, too, as my OCD cannot stand those plural/singular mismatches ;-) But Niklas does have a valid point... Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds
diff --git a/drivers/thermal/rcar_gen3_thermal.c b/drivers/thermal/rcar_gen3_thermal.c index ccdf8a24ddc7..f7357b5bd506 100644 --- a/drivers/thermal/rcar_gen3_thermal.c +++ b/drivers/thermal/rcar_gen3_thermal.c @@ -511,7 +511,7 @@ static int rcar_gen3_thermal_probe(struct platform_device *pdev) zone = devm_thermal_zone_of_sensor_register(dev, i, tsc, &rcar_gen3_tz_of_ops); if (IS_ERR(zone)) { - dev_err(dev, "Can't register thermal zone\n"); + dev_err(dev, "Sensor %u: Can't register thermal zone\n", i); ret = PTR_ERR(zone); goto error_unregister; } @@ -533,7 +533,8 @@ static int rcar_gen3_thermal_probe(struct platform_device *pdev) if (ret < 0) goto error_unregister; - dev_info(dev, "TSC%u: Loaded %d trip points\n", i, ret); + dev_info(dev, "Sensor %u: Loaded %u trip point%s\n", i, ret, + ret == 1 ? "" : "s"); } if (!priv->num_tscs) {
When setting up a new board, a plain "Can't register thermal zone" didn't help me much because the thermal zones in DT were all fine. I just had a sensor entry too much in the parent TSC node. Reword the failure/success messages to contain the sensor number to make it easier to understand which sensor is affected. Example output now: rcar_gen3_thermal e6198000.thermal: Sensor 0: Loaded 1 trip point rcar_gen3_thermal e6198000.thermal: Sensor 1: Loaded 1 trip point rcar_gen3_thermal e6198000.thermal: Sensor 2: Loaded 1 trip point rcar_gen3_thermal e6198000.thermal: Sensor 3: Can't register thermal zone Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com> --- Change from v1: reword the dev_info string to be more like the original one. Added a check to add the plural-'s' only when needed. Geert: is this better now? drivers/thermal/rcar_gen3_thermal.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-)