Message ID | 20210127000303.436595-1-drew@beagleboard.org |
---|---|
State | New |
Headers | show |
Series | [1/2] ARM: dts: am335x-pocketbeagle: unique gpio-line-names | expand |
On Wed, Jan 27, 2021 at 1:04 AM Drew Fustini <drew@beagleboard.org> wrote: > > Based on linux-gpio discussion [1], it is best practice to make the > gpio-line-names unique. Generic names like "[ethernet]" are replaced > with the name of the unique signal on the AM3358 SoC ball corresponding > to the gpio line. "[NC]" is also renamed to the standard "NC" name to > represent "not connected". > > [1] https://lore.kernel.org/linux-gpio/20201216195357.GA2583366@x1/ > > Signed-off-by: Drew Fustini <drew@beagleboard.org> > --- Reviewed-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
* Drew Fustini <drew@beagleboard.org> [210127 02:04]: > Based on linux-gpio discussion [1], it is best practice to make the > gpio-line-names unique. Generic names like "[ethernet]" are replaced > with the name of the unique signal on the AM3358 SoC ball corresponding > to the gpio line. "[NC]" is also renamed to the standard "NC" name to > represent "not connected". > > [1] https://lore.kernel.org/linux-gpio/20201216195357.GA2583366@x1/ So are these needed for v5.12 as fixes, or can these wait until after the merge window for v5.13? Regards, Tony
On Thu, Feb 04, 2021 at 08:58:20AM +0200, Tony Lindgren wrote: > * Drew Fustini <drew@beagleboard.org> [210127 02:04]: > > Based on linux-gpio discussion [1], it is best practice to make the > > gpio-line-names unique. Generic names like "[ethernet]" are replaced > > with the name of the unique signal on the AM3358 SoC ball corresponding > > to the gpio line. "[NC]" is also renamed to the standard "NC" name to > > represent "not connected". > > > > [1] https://lore.kernel.org/linux-gpio/20201216195357.GA2583366@x1/ > > So are these needed for v5.12 as fixes, or can these wait until after > the merge window for v5.13? > > Regards, > > Tony I suppose it depends on if/when the patches to make gpio lines unique go in. I believe the last response from Linus W. was in mid-December and indicated he holding off merging as it was immature [1] Thanks, Drew [1] https://lore.kernel.org/linux-gpio/CACRpkdbXRHCDGX-YBbNY7cMob0dZNhi1ETA3QnC71ZtOYB30JQ@mail.gmail.com/
On Thu, Feb 4, 2021 at 8:47 AM Drew Fustini <drew@beagleboard.org> wrote: > On Thu, Feb 04, 2021 at 08:58:20AM +0200, Tony Lindgren wrote: > > * Drew Fustini <drew@beagleboard.org> [210127 02:04]: > > > Based on linux-gpio discussion [1], it is best practice to make the > > > gpio-line-names unique. Generic names like "[ethernet]" are replaced > > > with the name of the unique signal on the AM3358 SoC ball corresponding > > > to the gpio line. "[NC]" is also renamed to the standard "NC" name to > > > represent "not connected". > > > > > > [1] https://lore.kernel.org/linux-gpio/20201216195357.GA2583366@x1/ > > > > So are these needed for v5.12 as fixes, or can these wait until after > > the merge window for v5.13? > > > > Regards, > > > > Tony > > I suppose it depends on if/when the patches to make gpio lines unique > go in. I believe the last response from Linus W. was in mid-December > and indicated he holding off merging as it was immature [1] There is no hurry with that plus I hold that patch back indefinately as it seems. I want to make line names unique for devices not probing from DT but DT devices, I dunno. Yours, Linus Walleij
Hi, * Drew Fustini <drew@beagleboard.org> [210127 02:04]: > Based on linux-gpio discussion [1], it is best practice to make the > gpio-line-names unique. Generic names like "[ethernet]" are replaced > with the name of the unique signal on the AM3358 SoC ball corresponding > to the gpio line. "[NC]" is also renamed to the standard "NC" name to > represent "not connected". Applying this one into omap-for-v5.13/dt thanks. However the second patch does not apply against v5.12-rc2, Drew can you please repost the second patch? Regards, Tony
On Wed, Mar 24, 2021 at 02:00:52PM +0200, Tony Lindgren wrote: > Hi, > > * Drew Fustini <drew@beagleboard.org> [210127 02:04]: > > Based on linux-gpio discussion [1], it is best practice to make the > > gpio-line-names unique. Generic names like "[ethernet]" are replaced > > with the name of the unique signal on the AM3358 SoC ball corresponding > > to the gpio line. "[NC]" is also renamed to the standard "NC" name to > > represent "not connected". > > Applying this one into omap-for-v5.13/dt thanks. However the second patch > does not apply against v5.12-rc2, Drew can you please repost the second > patch? > > Regards, > > Tony Hi Tony, I have posted a new patch that applies okay to mainline. Thanks, Drew [1] https://lore.kernel.org/linux-gpio/20210324222201.674905-1-drew@beagleboard.org/T/#u
diff --git a/arch/arm/boot/dts/am335x-pocketbeagle.dts b/arch/arm/boot/dts/am335x-pocketbeagle.dts index d526c5941c9b..209cdd17dc1e 100644 --- a/arch/arm/boot/dts/am335x-pocketbeagle.dts +++ b/arch/arm/boot/dts/am335x-pocketbeagle.dts @@ -61,51 +61,51 @@ vmmcsd_fixed: fixedregulator0 { &gpio0 { gpio-line-names = - "[NC]", - "[NC]", + "NC", + "NC", "P1.08 [SPI0_CLK]", "P1.10 [SPI0_MISO]", "P1.12 [SPI0_MOSI]", "P1.06 [SPI0_CS]", "[MMC0_CD]", "P2.29 [SPI1_CLK]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", + "[SYSBOOT 12]", + "[SYSBOOT 13]", + "[SYSBOOT 14]", + "[SYSBOOT 15]", "P1.26 [I2C2_SDA]", "P1.28 [I2C2_SCL]", "P2.11 [I2C1_SDA]", "P2.09 [I2C1_SCL]", - "[NC]", - "[NC]", - "[NC]", + "NC", + "NC", + "NC", "P2.31 [SPI1_CS]", "P1.20 [PRU0.16]", - "[NC]", - "[NC]", + "NC", + "NC", "P2.03", - "[NC]", - "[NC]", + "NC", + "NC", "P1.34", "P2.19", - "[NC]", - "[NC]", + "NC", + "NC", "P2.05 [UART4_RX]", "P2.07 [UART4_TX]"; }; &gpio1 { gpio-line-names = - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", "P2.25 [SPI1_MOSI]", "P1.32 [UART0_RX]", "P1.30 [UART0_TX]", @@ -113,10 +113,10 @@ &gpio1 { "P2.33", "P2.22", "P2.18", - "[NC]", - "[NC]", + "NC", + "NC", "P2.01 [PWM1A]", - "[NC]", + "NC", "P2.10", "[USR LED 0]", "[USR LED 1]", @@ -126,35 +126,35 @@ &gpio1 { "P2.04", "P2.02", "P2.08", - "[NC]", - "[NC]", - "[NC]"; + "NC", + "NC", + "NC"; }; &gpio2 { gpio-line-names = "P2.20", "P2.17", - "[NC]", - "[NC]", - "[NC]", + "NC", + "NC", + "NC", "[EEPROM_WP]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[SYSBOOT]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", + "[SYSBOOT 0]", + "[SYSBOOT 1]", + "[SYSBOOT 2]", + "[SYSBOOT 3]", + "[SYSBOOT 4]", + "[SYSBOOT 5]", + "[SYSBOOT 6]", + "[SYSBOOT 7]", + "[SYSBOOT 8]", + "[SYSBOOT 9]", + "[SYSBOOT 10]", + "[SYSBOOT 11]", + "NC", + "NC", + "NC", + "NC", "P2.35 [AIN5]", "P1.02 [AIN6]", "P1.35 [PRU1.10]", @@ -169,19 +169,19 @@ &gpio2 { &gpio3 { gpio-line-names = - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", + "NC", + "NC", + "NC", + "NC", + "NC", "[I2C0_SDA]", "[I2C0_SCL]", - "[JTAG]", - "[JTAG]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", + "[JTAG EMU0]", + "[JTAG EMU1]", + "NC", + "NC", + "NC", + "NC", "P1.03 [USB1]", "P1.36 [PWM0A]", "P1.33 [PRU0.1]", @@ -191,16 +191,16 @@ &gpio3 { "P2.34 [PRU0.5]", "P2.28 [PRU0.6]", "P1.29 [PRU0.7]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]", - "[NC]"; + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC", + "NC"; }; &am33xx_pinmux {
Based on linux-gpio discussion [1], it is best practice to make the gpio-line-names unique. Generic names like "[ethernet]" are replaced with the name of the unique signal on the AM3358 SoC ball corresponding to the gpio line. "[NC]" is also renamed to the standard "NC" name to represent "not connected". [1] https://lore.kernel.org/linux-gpio/20201216195357.GA2583366@x1/ Signed-off-by: Drew Fustini <drew@beagleboard.org> --- arch/arm/boot/dts/am335x-pocketbeagle.dts | 140 +++++++++++----------- 1 file changed, 70 insertions(+), 70 deletions(-)