mbox series

[v2,0/3] Add lockdep_assert_not_held()

Message ID cover.1614355914.git.skhan@linuxfoundation.org
Headers show
Series Add lockdep_assert_not_held() | expand

Message

Shuah Khan Feb. 26, 2021, 5:52 p.m. UTC
Some kernel functions must not be called holding a specific lock. Doing
so could lead to locking problems. Currently these routines call
lock_is_held() to check for lock hold followed by WARN_ON.

Adding a common lockdep interface will help reduce the duplication of this
logic in the rest of the kernel.

Add lockdep_assert_not_held() to be used in these functions to detect
incorrect calls while holding a lock.

lockdep_assert_not_held() provides the opposite functionality of
lockdep_assert_held() which is used to assert calls that require
holding a specific lock.

The need for lockdep_assert_not_held() came up in a discussion on
ath10k patch. ath10k_drain_tx() and i915_vma_pin_ww() are examples
of functions that can use lockdep_assert_not_held().

Link: https://lore.kernel.org/lkml/37a29c383bff2fb1605241ee6c7c9be3784fb3c6.1613171185.git.skhan@linuxfoundation.org/
Link: https://lore.kernel.org/linux-wireless/871rdmu9z9.fsf@codeaurora.org/

This patch series adds lockdep_assert_not_held() and uses it in the
second patch in ath10k_drain_tx() function.

Patch 1 incorporates suggestions from Peter Zijlstra on v1 series
to avoid misfires when lockdep_off() is employed.

Patch 2 Johannes Berg's suggestions as it make it easier to read and
maintain the lock states. These are defines and a enum to avoid changes
to lock_is_held_type() and lockdep_is_held() return types.

Patch 2 is a separate patch because it adds defines to lockdep.h and
kernel/locking/lockdep.c now includes lockdep.h - decided make this
a separate patch just in case issues related to header dependencies
pop up. I can combine Patches 1&2 if that is preferred.

Patch 3 uses the new interface in ath10k_drain_tx() function. Added
Kalle Valo's Ack from v1 for this change.

Tested on the mainline from yesterday.

Shuah Khan (3):
  lockdep: add lockdep_assert_not_held()
  lockdep: add lockdep lock state defines
  ath10k: detect conf_mutex held ath10k_drain_tx() calls

 drivers/net/wireless/ath/ath10k/mac.c |  2 ++
 include/linux/lockdep.h               | 18 +++++++++++++++---
 kernel/locking/lockdep.c              |  6 +++++-
 3 files changed, 22 insertions(+), 4 deletions(-)

Comments

Shuah Khan Feb. 26, 2021, 6:16 p.m. UTC | #1
On 2/26/21 11:03 AM, Johannes Berg wrote:
> 
>> @@ -5475,7 +5476,7 @@ noinstr int lock_is_held_type(const struct lockdep_map *lock, int read)
>>   		/* avoid false negative lockdep_assert_not_held()
>>   		 * and lockdep_assert_held()
>>   		 */
>> -		return -1;
>> +		return LOCK_STATE_UNKNOWN;
> 
> I'd argue that then the other two return places here should also be
> changed.
> 

Makes sense.

Since lock_is_held_type() simply returns what  __lock_is_held() for the
other cases, __lock_is_held() is the one that needs changes to use these 
defines.

thanks,
-- Shuah
Shuah Khan Feb. 26, 2021, 9:16 p.m. UTC | #2
On 2/26/21 2:07 PM, Peter Zijlstra wrote:
> On Fri, Feb 26, 2021 at 10:52:13AM -0700, Shuah Khan wrote:
>> +		/* avoid false negative lockdep_assert_not_held()
>> +		 * and lockdep_assert_held()
>> +		 */
> 
> That's a coding style fail.
> 

Checkpatch didn't complain. What's your preference? Does the
following work for you?

/*
  * avoid false negative lockdep_assert_not_held()
  * and lockdep_assert_held()
  */

thanks,
-- Shuah
Peter Zijlstra March 1, 2021, 8:28 a.m. UTC | #3
On Fri, Feb 26, 2021 at 02:16:12PM -0700, Shuah Khan wrote:
> On 2/26/21 2:07 PM, Peter Zijlstra wrote:

> > On Fri, Feb 26, 2021 at 10:52:13AM -0700, Shuah Khan wrote:

> > > +		/* avoid false negative lockdep_assert_not_held()

> > > +		 * and lockdep_assert_held()

> > > +		 */

> > 

> > That's a coding style fail.

> > 

> 

> Checkpatch didn't complain.


  Documentation/CodingStyle

(or whatever unreadable rst crap it is today :-( )

and:

  https://lkml.kernel.org/lkml/CA+55aFyQYJerovMsSoSKS7PessZBr4vNp-3QUUwhqk4A4_jcbg@mail.gmail.com/

> What's your preference? Does the following work for you?

> 

> /*

>  * avoid false negative lockdep_assert_not_held()

>  * and lockdep_assert_held()

>  */


Yep (ideally even with a Capital and full stop).