Message ID | 20210120015010.14191-1-digetx@gmail.com |
---|---|
Headers | show |
Series | GENPD API improvements | expand |
On Wed, 20 Jan 2021 at 05:39, Viresh Kumar <viresh.kumar@linaro.org> wrote: > > On 20-01-21, 04:50, Dmitry Osipenko wrote: > > Make set_performance_state() callback optional in order to remove the > > need from power domain drivers to implement a dummy callback. If callback > > isn't implemented by a GENPD driver, then the performance state is passed > > to the parent domain. > > > > Tested-by: Peter Geis <pgwipeout@gmail.com> > > Tested-by: Nicolas Chauvet <kwizart@gmail.com> > > Tested-by: Matt Merhar <mattmerhar@protonmail.com> > > [tested on NVIDIA Tegra20/30/124 SoCs] > > Suggested-by: Ulf Hansson <ulf.hansson@linaro.org> > > Signed-off-by: Dmitry Osipenko <digetx@gmail.com> > > --- > > drivers/base/power/domain.c | 33 ++++++++++++++++++--------------- > > 1 file changed, 18 insertions(+), 15 deletions(-) > > > > diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c > > index 9a14eedacb92..0bd0cdc30393 100644 > > --- a/drivers/base/power/domain.c > > +++ b/drivers/base/power/domain.c > > @@ -297,6 +297,18 @@ static int _genpd_reeval_performance_state(struct generic_pm_domain *genpd, > > return state; > > } > > > > +static int _genpd_xlate_performance_state(struct generic_pm_domain *src_genpd, > > + struct generic_pm_domain *dst_genpd, > > + unsigned int pstate) > > I would name them as genpd and parent, that makes it more readable for it. ... and while at it, probably also drop the "_" as the prefix of the function name. Other than that, please add: Reviewed-by: Ulf Hansson <ulf.hansson@linaro.org> Kind regards Uffe