mbox series

[v2,0/5] Introduce a new helper marco DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c

Message ID 1604046722-15531-1-git-send-email-luojiaxing@huawei.com
Headers show
Series Introduce a new helper marco DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c | expand

Message

luojiaxing Oct. 30, 2020, 8:31 a.m. UTC
We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper marco for
read-write file too.

So we try to add this macro to help decrease code duplication.

Luo Jiaxing (5):
  seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
  scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
  scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
  usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
  drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

 .../gpu/drm/i915/display/intel_display_debugfs.c   |  55 +--------
 drivers/scsi/hisi_sas/hisi_sas_main.c              | 135 +++------------------
 drivers/scsi/qla2xxx/qla_dfs.c                     |  19 +--
 drivers/usb/dwc3/debugfs.c                         |  52 +-------
 include/linux/seq_file.h                           |  15 +++
 5 files changed, 41 insertions(+), 235 deletions(-)

Comments

Greg KH Oct. 30, 2020, 8:44 a.m. UTC | #1
On Fri, Oct 30, 2020 at 04:31:57PM +0800, Luo Jiaxing wrote:
> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
> for read-only file, but we found many of drivers also want a helper marco for
> read-write file too.
> 
> So we try to add this macro to help decrease code duplication.
> 
> Luo Jiaxing (5):
>   seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
>   scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
>   scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
>   usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
>   drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

What changed from v1?

thanks,

greg k-h
luojiaxing Nov. 3, 2020, 8:19 a.m. UTC | #2
Hi

On 2020/10/30 16:44, Greg KH wrote:
> On Fri, Oct 30, 2020 at 04:31:57PM +0800, Luo Jiaxing wrote:

>> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute

>> for read-only file, but we found many of drivers also want a helper marco for

>> read-write file too.

>>

>> So we try to add this macro to help decrease code duplication.

>>

>> Luo Jiaxing (5):

>>    seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro

>>    scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

>>    scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

>>    usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE

>>    drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

> What changed from v1?



Sorry, I should add a commit for the change.


In v1, Andy pointed out that the old name of DEFINE_STORE_ATTRIBUTE was 
easily misunderstood as a write-only file rather than a read-write file.

Therefore, it is changed to DEFINE_SHOW_STORE_ATTRIBUTE according to his 
suggestion.


Thanks

Jiaxing


>

> thanks,

>

> greg k-h

>

> .

>
Greg KH Nov. 3, 2020, 8:27 a.m. UTC | #3
On Tue, Nov 03, 2020 at 04:19:09PM +0800, luojiaxing wrote:
> Hi

> 

> On 2020/10/30 16:44, Greg KH wrote:

> > On Fri, Oct 30, 2020 at 04:31:57PM +0800, Luo Jiaxing wrote:

> > > We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute

> > > for read-only file, but we found many of drivers also want a helper marco for

> > > read-write file too.

> > > 

> > > So we try to add this macro to help decrease code duplication.

> > > 

> > > Luo Jiaxing (5):

> > >    seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro

> > >    scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

> > >    scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

> > >    usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE

> > >    drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

> > What changed from v1?

> 

> 

> Sorry, I should add a commit for the change.

> 

> 

> In v1, Andy pointed out that the old name of DEFINE_STORE_ATTRIBUTE was

> easily misunderstood as a write-only file rather than a read-write file.

> 

> Therefore, it is changed to DEFINE_SHOW_STORE_ATTRIBUTE according to his

> suggestion.


All of that needs to go in the patch, below the --- line, or in the
00/XX email here, like is documented.

Please fix that up and resend a v3 if you wish for people to look at
this series and know what is going on.

thanks,

greg k-h