Message ID | 1385982538-17855-2-git-send-email-andre.przywara@linaro.org |
---|---|
State | New |
Headers | show |
On 12/02/2013 11:08 AM, Andre Przywara wrote: > Follow the current convention of prefixing guest related names > with "v" by renaming the guest PSCI functionality into vpsci.c to make > room for the host PSCI functions. I would also rename the header asm/psci.h => asm/vpsci.h > > Signed-off-by: Andre Przywara <andre.przywara@linaro.org> > --- > xen/arch/arm/Makefile | 2 +- > xen/arch/arm/{psci.c => vpsci.c} | 0 > 2 files changed, 1 insertion(+), 1 deletion(-) > rename xen/arch/arm/{psci.c => vpsci.c} (100%) > > diff --git a/xen/arch/arm/Makefile b/xen/arch/arm/Makefile > index 003ac84..11cf663 100644 > --- a/xen/arch/arm/Makefile > +++ b/xen/arch/arm/Makefile > @@ -5,7 +5,7 @@ subdir-y += platforms > obj-$(EARLY_PRINTK) += early_printk.o > obj-y += cpu.o > obj-y += domain.o > -obj-y += psci.o > +obj-y += vpsci.o > obj-y += domctl.o > obj-y += sysctl.o > obj-y += domain_build.o > diff --git a/xen/arch/arm/psci.c b/xen/arch/arm/vpsci.c > similarity index 100% > rename from xen/arch/arm/psci.c > rename to xen/arch/arm/vpsci.c >
On Mon, 2013-12-02 at 13:02 +0000, Julien Grall wrote: > > On 12/02/2013 11:08 AM, Andre Przywara wrote: > > Follow the current convention of prefixing guest related names > > with "v" by renaming the guest PSCI functionality into vpsci.c to make > > room for the host PSCI functions. > > I would also rename the header asm/psci.h => asm/vpsci.h The majority of the header is stuff defined by the spec which is equally common to be host and guest psci. Apart from a couple of prototypes for the guest entry points. I don't think it makes sense to rename the header, or even to split the tiny guest side parts into a new vpsci.h Ian.
On 12/02/2013 01:06 PM, Ian Campbell wrote: > On Mon, 2013-12-02 at 13:02 +0000, Julien Grall wrote: >> >> On 12/02/2013 11:08 AM, Andre Przywara wrote: >>> Follow the current convention of prefixing guest related names >>> with "v" by renaming the guest PSCI functionality into vpsci.c to make >>> room for the host PSCI functions. >> >> I would also rename the header asm/psci.h => asm/vpsci.h > > The majority of the header is stuff defined by the spec which is equally > common to be host and guest psci. Apart from a couple of prototypes for > the guest entry points. > > I don't think it makes sense to rename the header, or even to split the > tiny guest side parts into a new vpsci.h In this case, can we at least add "guest" (or something else) in the function name?
On Mon, 2013-12-02 at 12:08 +0100, Andre Przywara wrote: > Follow the current convention of prefixing guest related names > with "v" by renaming the guest PSCI functionality into vpsci.c to make > room for the host PSCI functions. > > Signed-off-by: Andre Przywara <andre.przywara@linaro.org> Acked-by: Ian Campbell <ian.campbell@citrix.com>
diff --git a/xen/arch/arm/Makefile b/xen/arch/arm/Makefile index 003ac84..11cf663 100644 --- a/xen/arch/arm/Makefile +++ b/xen/arch/arm/Makefile @@ -5,7 +5,7 @@ subdir-y += platforms obj-$(EARLY_PRINTK) += early_printk.o obj-y += cpu.o obj-y += domain.o -obj-y += psci.o +obj-y += vpsci.o obj-y += domctl.o obj-y += sysctl.o obj-y += domain_build.o
Follow the current convention of prefixing guest related names with "v" by renaming the guest PSCI functionality into vpsci.c to make room for the host PSCI functions. Signed-off-by: Andre Przywara <andre.przywara@linaro.org> --- xen/arch/arm/Makefile | 2 +- xen/arch/arm/{psci.c => vpsci.c} | 0 2 files changed, 1 insertion(+), 1 deletion(-) rename xen/arch/arm/{psci.c => vpsci.c} (100%) diff --git a/xen/arch/arm/psci.c b/xen/arch/arm/vpsci.c similarity index 100% rename from xen/arch/arm/psci.c rename to xen/arch/arm/vpsci.c