Message ID | 1436551413-2609-1-git-send-email-bill.fischofer@linaro.org |
---|---|
State | New |
Headers | show |
On 07/10/15 21:03, Bill Fischofer wrote: > Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> > --- > include/odp/api/queue.h | 10 ++++++++++ > 1 file changed, 10 insertions(+) > > diff --git a/include/odp/api/queue.h b/include/odp/api/queue.h > index 297067d..61e7ace 100644 > --- a/include/odp/api/queue.h > +++ b/include/odp/api/queue.h > @@ -258,6 +258,16 @@ odp_schedule_group_t odp_queue_sched_group(odp_queue_t queue); > uint64_t odp_queue_to_u64(odp_queue_t hdl); > > /** > + * Initialize queue params > + * > + * This routine is used to initialize an odp_queue_param_t to its > + * default values for all fields > + * > + * @param param Address of the odp_queue_param_t to be initialized I have thoughts that we should define the same style for all function descriptions. Words likes: "This routine is used to" "This routine is intended to be used for" are useless for function description. And might be omitted to have more short and exact wording for functions. Having them in @warning and @note looks like ok. Maxim. > + */ > +void odp_queue_param_init(odp_queue_param_t *param); > + > +/** > * @} > */ >
The wording was just a copy of odp_pool_param_init(), which was reviewed by Petri and has already been merged. No objections to changing this if you'd prefer. On Tue, Jul 14, 2015 at 4:35 AM, Maxim Uvarov <maxim.uvarov@linaro.org> wrote: > On 07/10/15 21:03, Bill Fischofer wrote: > >> Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> >> --- >> include/odp/api/queue.h | 10 ++++++++++ >> 1 file changed, 10 insertions(+) >> >> diff --git a/include/odp/api/queue.h b/include/odp/api/queue.h >> index 297067d..61e7ace 100644 >> --- a/include/odp/api/queue.h >> +++ b/include/odp/api/queue.h >> @@ -258,6 +258,16 @@ odp_schedule_group_t >> odp_queue_sched_group(odp_queue_t queue); >> uint64_t odp_queue_to_u64(odp_queue_t hdl); >> /** >> + * Initialize queue params >> + * >> + * This routine is used to initialize an odp_queue_param_t to its >> + * default values for all fields >> + * >> + * @param param Address of the odp_queue_param_t to be initialized >> > I have thoughts that we should define the same style for all function > descriptions. > Words likes: > > "This routine is used to" > "This routine is intended to be used for" > > are useless for function description. And might be omitted to have more > short and exact wording for functions. > Having them in @warning and @note looks like ok. > > Maxim. > > + */ >> +void odp_queue_param_init(odp_queue_param_t *param); >> + >> +/** >> * @} >> */ >> >> > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > https://lists.linaro.org/mailman/listinfo/lng-odp >
On 07/14/15 14:38, Bill Fischofer wrote: > The wording was just a copy of odp_pool_param_init(), which was > reviewed by Petri and has already been merged. No objections to > changing this if you'd prefer. That is minor and probably we need to define common style and fix existence wording at the same time. I did not make attention to that in initial time, but I like that things short and exact. Maxim. > > On Tue, Jul 14, 2015 at 4:35 AM, Maxim Uvarov <maxim.uvarov@linaro.org > <mailto:maxim.uvarov@linaro.org>> wrote: > > On 07/10/15 21:03, Bill Fischofer wrote: > > Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org > <mailto:bill.fischofer@linaro.org>> > --- > include/odp/api/queue.h | 10 ++++++++++ > 1 file changed, 10 insertions(+) > > diff --git a/include/odp/api/queue.h b/include/odp/api/queue.h > index 297067d..61e7ace 100644 > --- a/include/odp/api/queue.h > +++ b/include/odp/api/queue.h > @@ -258,6 +258,16 @@ odp_schedule_group_t > odp_queue_sched_group(odp_queue_t queue); > uint64_t odp_queue_to_u64(odp_queue_t hdl); > /** > + * Initialize queue params > + * > + * This routine is used to initialize an odp_queue_param_t to its > + * default values for all fields > + * > + * @param param Address of the odp_queue_param_t to be > initialized > > I have thoughts that we should define the same style for all > function descriptions. > Words likes: > > "This routine is used to" > "This routine is intended to be used for" > > are useless for function description. And might be omitted to have > more short and exact wording for functions. > Having them in @warning and @note looks like ok. > > Maxim. > > + */ > +void odp_queue_param_init(odp_queue_param_t *param); > + > +/** > * @} > */ > > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org <mailto:lng-odp@lists.linaro.org> > https://lists.linaro.org/mailman/listinfo/lng-odp > >
Agreed. Let me resubmit this patch and we can then do a parallel one for the pool_init routine. Bill On Tue, Jul 14, 2015 at 6:55 AM, Maxim Uvarov <maxim.uvarov@linaro.org> wrote: > On 07/14/15 14:38, Bill Fischofer wrote: > >> The wording was just a copy of odp_pool_param_init(), which was reviewed >> by Petri and has already been merged. No objections to changing this if >> you'd prefer. >> > > That is minor and probably we need to define common style and fix > existence wording at the same time. I did not make attention to that in > initial time, > but I like that things short and exact. > > Maxim. > > >> On Tue, Jul 14, 2015 at 4:35 AM, Maxim Uvarov <maxim.uvarov@linaro.org >> <mailto:maxim.uvarov@linaro.org>> wrote: >> >> On 07/10/15 21:03, Bill Fischofer wrote: >> >> Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org >> <mailto:bill.fischofer@linaro.org>> >> >> --- >> include/odp/api/queue.h | 10 ++++++++++ >> 1 file changed, 10 insertions(+) >> >> diff --git a/include/odp/api/queue.h b/include/odp/api/queue.h >> index 297067d..61e7ace 100644 >> --- a/include/odp/api/queue.h >> +++ b/include/odp/api/queue.h >> @@ -258,6 +258,16 @@ odp_schedule_group_t >> odp_queue_sched_group(odp_queue_t queue); >> uint64_t odp_queue_to_u64(odp_queue_t hdl); >> /** >> + * Initialize queue params >> + * >> + * This routine is used to initialize an odp_queue_param_t to its >> + * default values for all fields >> + * >> + * @param param Address of the odp_queue_param_t to be >> initialized >> >> I have thoughts that we should define the same style for all >> function descriptions. >> Words likes: >> >> "This routine is used to" >> "This routine is intended to be used for" >> >> are useless for function description. And might be omitted to have >> more short and exact wording for functions. >> Having them in @warning and @note looks like ok. >> >> Maxim. >> >> + */ >> +void odp_queue_param_init(odp_queue_param_t *param); >> + >> +/** >> * @} >> */ >> >> >> _______________________________________________ >> lng-odp mailing list >> lng-odp@lists.linaro.org <mailto:lng-odp@lists.linaro.org> >> https://lists.linaro.org/mailman/listinfo/lng-odp >> >> >> >
diff --git a/include/odp/api/queue.h b/include/odp/api/queue.h index 297067d..61e7ace 100644 --- a/include/odp/api/queue.h +++ b/include/odp/api/queue.h @@ -258,6 +258,16 @@ odp_schedule_group_t odp_queue_sched_group(odp_queue_t queue); uint64_t odp_queue_to_u64(odp_queue_t hdl); /** + * Initialize queue params + * + * This routine is used to initialize an odp_queue_param_t to its + * default values for all fields + * + * @param param Address of the odp_queue_param_t to be initialized + */ +void odp_queue_param_init(odp_queue_param_t *param); + +/** * @} */
Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> --- include/odp/api/queue.h | 10 ++++++++++ 1 file changed, 10 insertions(+)