Message ID | 1424701112-23557-1-git-send-email-bala.manoharan@linaro.org |
---|---|
State | Accepted |
Commit | 17b5ab7057805861790e1289cfe2f913882328e1 |
Headers | show |
On Mon, Feb 23, 2015 at 8:18 AM, <bala.manoharan@linaro.org> wrote: > From: Balasubramanian Manoharan <bala.manoharan@linaro.org> > > Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros > https://bugs.linaro.org/show_bug.cgi?id=1208 > > Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> > Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> > --- > include/odp/api/classification.h | 12 ++++++++++++ > 1 file changed, 12 insertions(+) > > diff --git a/include/odp/api/classification.h > b/include/odp/api/classification.h > index 8758fb5..7db3645 100644 > --- a/include/odp/api/classification.h > +++ b/include/odp/api/classification.h > @@ -48,6 +48,18 @@ extern "C" { > */ > > /** > + * @def ODP_PMR_INVAL > + * Invalid odp_pmr_t value. > + * This value is returned from odp_pmr_create_match() and > + * odp_pmr_create_range() functions on failure. > + */ > + > +/** > + * @def ODP_PMR_SET_INVAL > + * Invalid odp_pmr_set_t value. > + */ > + > +/** > * Class-of-service packet drop policies > */ > typedef enum odp_cos_drop { > -- > 2.0.1.472.g6f92e5f > > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > http://lists.linaro.org/mailman/listinfo/lng-odp >
On 23 February 2015 at 12:27, Mike Holmes <mike.holmes@linaro.org> wrote: > On 2015-02-23 19:48, bala.manoharan@linaro.org wrote: > > From: Balasubramanian Manoharan <bala.manoharan@linaro.org> > > > > Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros > > https://bugs.linaro.org/show_bug.cgi?id=1208 > > > > Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> > > > --- > > include/odp/api/classification.h | 12 ++++++++++++ > > 1 file changed, 12 insertions(+) > > > > diff --git a/include/odp/api/classification.h > b/include/odp/api/classification.h > > index 8758fb5..7db3645 100644 > > --- a/include/odp/api/classification.h > > +++ b/include/odp/api/classification.h > > @@ -48,6 +48,18 @@ extern "C" { > > */ > > > > /** > > + * @def ODP_PMR_INVAL > > + * Invalid odp_pmr_t value. > > + * This value is returned from odp_pmr_create_match() and > > + * odp_pmr_create_range() functions on failure. > Is listing the function names a good idea, what this gets returned form another fun in future, will it get updated ? > > + */ > > + > > +/** > > + * @def ODP_PMR_SET_INVAL > > + * Invalid odp_pmr_set_t value. > > The comment on ODP_PMR_IVAL gives a greater indication what the > definition is used for, the text here does not add anything or > crossrefernece to further information, can this have a better description > in some way ? > > > + */ > > + > > +/** > > * Class-of-service packet drop policies > > */ > > typedef enum odp_cos_drop { > > -- > > 2.0.1.472.g6f92e5f > > > > > > _______________________________________________ > > lng-odp mailing list > > lng-odp@lists.linaro.org > > http://lists.linaro.org/mailman/listinfo/lng-odp >
On Tue, Feb 24, 2015 at 4:00 PM, Mike Holmes <mike.holmes@linaro.org> wrote: > > > On 23 February 2015 at 12:27, Mike Holmes <mike.holmes@linaro.org> wrote: > >> On 2015-02-23 19:48, bala.manoharan@linaro.org wrote: >> > From: Balasubramanian Manoharan <bala.manoharan@linaro.org> >> > >> > Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros >> > https://bugs.linaro.org/show_bug.cgi?id=1208 >> > >> > Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> >> >> > --- >> > include/odp/api/classification.h | 12 ++++++++++++ >> > 1 file changed, 12 insertions(+) >> > >> > diff --git a/include/odp/api/classification.h >> b/include/odp/api/classification.h >> > index 8758fb5..7db3645 100644 >> > --- a/include/odp/api/classification.h >> > +++ b/include/odp/api/classification.h >> > @@ -48,6 +48,18 @@ extern "C" { >> > */ >> > >> > /** >> > + * @def ODP_PMR_INVAL >> > + * Invalid odp_pmr_t value. >> > + * This value is returned from odp_pmr_create_match() and >> > + * odp_pmr_create_range() functions on failure. >> > > Is listing the function names a good idea, what this gets returned form > another fun in future, will it get updated ? > Any API change (that includes renames) requires careful planning. Given the impact of renames, doc updates are a minor thing. > > >> > + */ >> > + >> > +/** >> > + * @def ODP_PMR_SET_INVAL >> > + * Invalid odp_pmr_set_t value. >> >> The comment on ODP_PMR_IVAL gives a greater indication what the >> definition is used for, the text here does not add anything or >> crossrefernece to further information, can this have a better description >> in some way ? >> >> > + */ >> > + >> > +/** >> > * Class-of-service packet drop policies >> > */ >> > typedef enum odp_cos_drop { >> > -- >> > 2.0.1.472.g6f92e5f >> > >> > >> > _______________________________________________ >> > lng-odp mailing list >> > lng-odp@lists.linaro.org >> > http://lists.linaro.org/mailman/listinfo/lng-odp >> > > > > -- > *Mike Holmes* > Linaro Sr Technical Manager > LNG - ODP > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > http://lists.linaro.org/mailman/listinfo/lng-odp > >
Merged, Maxim. On 02/23/2015 05:18 PM, bala.manoharan@linaro.org wrote: > From: Balasubramanian Manoharan <bala.manoharan@linaro.org> > > Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros > https://bugs.linaro.org/show_bug.cgi?id=1208 > > Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> > --- > include/odp/api/classification.h | 12 ++++++++++++ > 1 file changed, 12 insertions(+) > > diff --git a/include/odp/api/classification.h b/include/odp/api/classification.h > index 8758fb5..7db3645 100644 > --- a/include/odp/api/classification.h > +++ b/include/odp/api/classification.h > @@ -48,6 +48,18 @@ extern "C" { > */ > > /** > + * @def ODP_PMR_INVAL > + * Invalid odp_pmr_t value. > + * This value is returned from odp_pmr_create_match() and > + * odp_pmr_create_range() functions on failure. > + */ > + > +/** > + * @def ODP_PMR_SET_INVAL > + * Invalid odp_pmr_set_t value. > + */ > + > +/** > * Class-of-service packet drop policies > */ > typedef enum odp_cos_drop {
Why is this merged - I have undressed comments ? > /** > > + * @def ODP_PMR_INVAL > > + * Invalid odp_pmr_t value. > > + * This value is returned from odp_pmr_create_match() and > > + * odp_pmr_create_range() functions on failure. > Is listing the function names a good idea, what this gets returned form another func in future, will it get updated ? > + * @def ODP_PMR_SET_INVAL > + * Invalid odp_pmr_set_t value. The comment on ODP_PMR_IVAL gives a greater indication what the definition is used for, the text here does not add anything or CrossRef to further information, can this have a better description in some way ? On 25 February 2015 at 04:33, Maxim Uvarov <maxim.uvarov@linaro.org> wrote: > Merged, > Maxim. > > > On 02/23/2015 05:18 PM, bala.manoharan@linaro.org wrote: > >> From: Balasubramanian Manoharan <bala.manoharan@linaro.org> >> >> Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros >> https://bugs.linaro.org/show_bug.cgi?id=1208 >> >> Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> >> --- >> include/odp/api/classification.h | 12 ++++++++++++ >> 1 file changed, 12 insertions(+) >> >> diff --git a/include/odp/api/classification.h b/include/odp/api/ >> classification.h >> index 8758fb5..7db3645 100644 >> --- a/include/odp/api/classification.h >> +++ b/include/odp/api/classification.h >> @@ -48,6 +48,18 @@ extern "C" { >> */ >> /** >> + * @def ODP_PMR_INVAL >> + * Invalid odp_pmr_t value. >> + * This value is returned from odp_pmr_create_match() and >> + * odp_pmr_create_range() functions on failure. >> + */ >> + >> +/** >> + * @def ODP_PMR_SET_INVAL >> + * Invalid odp_pmr_set_t value. >> + */ >> + >> +/** >> * Class-of-service packet drop policies >> */ >> typedef enum odp_cos_drop { >> > > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > http://lists.linaro.org/mailman/listinfo/lng-odp >
why does it say "linux-generic: classification: ..." should say: "api: classification: ..." Cheers, Anders On 23 February 2015 at 15:18, <bala.manoharan@linaro.org> wrote: > From: Balasubramanian Manoharan <bala.manoharan@linaro.org> > > Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros > https://bugs.linaro.org/show_bug.cgi?id=1208 > > Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> > --- > include/odp/api/classification.h | 12 ++++++++++++ > 1 file changed, 12 insertions(+) > > diff --git a/include/odp/api/classification.h > b/include/odp/api/classification.h > index 8758fb5..7db3645 100644 > --- a/include/odp/api/classification.h > +++ b/include/odp/api/classification.h > @@ -48,6 +48,18 @@ extern "C" { > */ > > /** > + * @def ODP_PMR_INVAL > + * Invalid odp_pmr_t value. > + * This value is returned from odp_pmr_create_match() and > + * odp_pmr_create_range() functions on failure. > + */ > + > +/** > + * @def ODP_PMR_SET_INVAL > + * Invalid odp_pmr_set_t value. > + */ > + > +/** > * Class-of-service packet drop policies > */ > typedef enum odp_cos_drop { > -- > 2.0.1.472.g6f92e5f > > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > http://lists.linaro.org/mailman/listinfo/lng-odp >
On 26 February 2015 at 03:43, Anders Roxell <anders.roxell@linaro.org> wrote: > why does it say "linux-generic: classification: ..." > > should say: "api: classification: ..." This is not an api change just adds documentation for PMR_INVAL and PMR_SET_INVAL macros Not sure if this should be also api: Regards, Bala > > Cheers, > Anders > > On 23 February 2015 at 15:18, <bala.manoharan@linaro.org> wrote: >> >> From: Balasubramanian Manoharan <bala.manoharan@linaro.org> >> >> Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros >> https://bugs.linaro.org/show_bug.cgi?id=1208 >> >> Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> >> --- >> include/odp/api/classification.h | 12 ++++++++++++ >> 1 file changed, 12 insertions(+) >> >> diff --git a/include/odp/api/classification.h >> b/include/odp/api/classification.h >> index 8758fb5..7db3645 100644 >> --- a/include/odp/api/classification.h >> +++ b/include/odp/api/classification.h >> @@ -48,6 +48,18 @@ extern "C" { >> */ >> >> /** >> + * @def ODP_PMR_INVAL >> + * Invalid odp_pmr_t value. >> + * This value is returned from odp_pmr_create_match() and >> + * odp_pmr_create_range() functions on failure. >> + */ >> + >> +/** >> + * @def ODP_PMR_SET_INVAL >> + * Invalid odp_pmr_set_t value. >> + */ >> + >> +/** >> * Class-of-service packet drop policies >> */ >> typedef enum odp_cos_drop { >> -- >> 2.0.1.472.g6f92e5f >> >> >> _______________________________________________ >> lng-odp mailing list >> lng-odp@lists.linaro.org >> http://lists.linaro.org/mailman/listinfo/lng-odp > >
On 26 February 2015 at 03:40, Mike Holmes <mike.holmes@linaro.org> wrote: > Why is this merged - I have undressed comments ? > >> > /** >> > + * @def ODP_PMR_INVAL >> > + * Invalid odp_pmr_t value. >> > + * This value is returned from odp_pmr_create_match() and >> > + * odp_pmr_create_range() functions on failure. > > > Is listing the function names a good idea, what this gets returned form > another func in future, will it get updated ? This value is returned as part of error only from these create functions. Maybe we can rename as PMR create functions. > > >> + * @def ODP_PMR_SET_INVAL >> + * Invalid odp_pmr_set_t value. > > The comment on ODP_PMR_IVAL gives a greater indication what the > definition is used for, the text here does not add anything or > CrossRef to further information, can this have a better description > in some way ? This Macro is for an invalid odp_pmr_set_t handle. If required we can add link to odp_pmr_set_t handle. Regards, Bala > > > > On 25 February 2015 at 04:33, Maxim Uvarov <maxim.uvarov@linaro.org> wrote: >> >> Merged, >> Maxim. >> >> >> On 02/23/2015 05:18 PM, bala.manoharan@linaro.org wrote: >>> >>> From: Balasubramanian Manoharan <bala.manoharan@linaro.org> >>> >>> Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros >>> https://bugs.linaro.org/show_bug.cgi?id=1208 >>> >>> Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> >>> --- >>> include/odp/api/classification.h | 12 ++++++++++++ >>> 1 file changed, 12 insertions(+) >>> >>> diff --git a/include/odp/api/classification.h >>> b/include/odp/api/classification.h >>> index 8758fb5..7db3645 100644 >>> --- a/include/odp/api/classification.h >>> +++ b/include/odp/api/classification.h >>> @@ -48,6 +48,18 @@ extern "C" { >>> */ >>> /** >>> + * @def ODP_PMR_INVAL >>> + * Invalid odp_pmr_t value. >>> + * This value is returned from odp_pmr_create_match() and >>> + * odp_pmr_create_range() functions on failure. >>> + */ >>> + >>> +/** >>> + * @def ODP_PMR_SET_INVAL >>> + * Invalid odp_pmr_set_t value. >>> + */ >>> + >>> +/** >>> * Class-of-service packet drop policies >>> */ >>> typedef enum odp_cos_drop { >> >> >> >> _______________________________________________ >> lng-odp mailing list >> lng-odp@lists.linaro.org >> http://lists.linaro.org/mailman/listinfo/lng-odp > > > > > -- > Mike Holmes > Linaro Sr Technical Manager > LNG - ODP > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > http://lists.linaro.org/mailman/listinfo/lng-odp >
On 02/26/2015 01:10 AM, Mike Holmes wrote: > Why is this merged - I have undressed comments ? > > >/** > > + * @def ODP_PMR_INVAL > > + * Invalid odp_pmr_t value. > > + * This value is returned from odp_pmr_create_match() and > > + * odp_pmr_create_range() functions on failure. > > > Is listing the function names a good idea, what this gets returned > form another func in future, will it get updated ? > Looks like I did not understand if it's simple question or request to rework. > > > + * @def ODP_PMR_SET_INVAL > > + * Invalid odp_pmr_set_t value. > > The comment on ODP_PMR_IVAL gives a greater indication what the > definition is used for, the text here does not add anything or > CrossRef to further information, can this have a better description > in some way ? > That comment is in quoted area at least in Thunderbird. But I think Bala just follow other code. The same thing we have for ODP_POOL_INVALID for example. Maxim. > > > On 25 February 2015 at 04:33, Maxim Uvarov <maxim.uvarov@linaro.org > <mailto:maxim.uvarov@linaro.org>> wrote: > > Merged, > Maxim. > > > On 02/23/2015 05:18 PM, bala.manoharan@linaro.org > <mailto:bala.manoharan@linaro.org> wrote: > > From: Balasubramanian Manoharan <bala.manoharan@linaro.org > <mailto:bala.manoharan@linaro.org>> > > Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros > https://bugs.linaro.org/show_bug.cgi?id=1208 > > Signed-off-by: Balasubramanian Manoharan > <bala.manoharan@linaro.org <mailto:bala.manoharan@linaro.org>> > --- > include/odp/api/classification.h | 12 ++++++++++++ > 1 file changed, 12 insertions(+) > > diff --git a/include/odp/api/classification.h > b/include/odp/api/classification.h > index 8758fb5..7db3645 100644 > --- a/include/odp/api/classification.h > +++ b/include/odp/api/classification.h > @@ -48,6 +48,18 @@ extern "C" { > */ > /** > + * @def ODP_PMR_INVAL > + * Invalid odp_pmr_t value. > + * This value is returned from odp_pmr_create_match() and > + * odp_pmr_create_range() functions on failure. > + */ > + > +/** > + * @def ODP_PMR_SET_INVAL > + * Invalid odp_pmr_set_t value. > + */ > + > +/** > * Class-of-service packet drop policies > */ > typedef enum odp_cos_drop { > > > > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org <mailto:lng-odp@lists.linaro.org> > http://lists.linaro.org/mailman/listinfo/lng-odp > > > > > -- > *Mike Holmes* > Linaro Sr Technical Manager > LNG - ODP
On 02/26/2015 05:10 AM, Bala Manoharan wrote: > On 26 February 2015 at 03:43, Anders Roxell <anders.roxell@linaro.org> wrote: >> why does it say "linux-generic: classification: ..." >> >> should say: "api: classification: ..." > This is not an api change just adds documentation for PMR_INVAL and > PMR_SET_INVAL macros > Not sure if this should be also api: > > Regards, > Bala The better name for this patch might be: "api: doxygen: classificaion: define ODP_PMR_INVAL" Maxim. >> Cheers, >> Anders >> >> On 23 February 2015 at 15:18, <bala.manoharan@linaro.org> wrote: >>> From: Balasubramanian Manoharan <bala.manoharan@linaro.org> >>> >>> Adds documentation for ODP_PMR_INVAL and ODP_PMR_SET_INVAL macros >>> https://bugs.linaro.org/show_bug.cgi?id=1208 >>> >>> Signed-off-by: Balasubramanian Manoharan <bala.manoharan@linaro.org> >>> --- >>> include/odp/api/classification.h | 12 ++++++++++++ >>> 1 file changed, 12 insertions(+) >>> >>> diff --git a/include/odp/api/classification.h >>> b/include/odp/api/classification.h >>> index 8758fb5..7db3645 100644 >>> --- a/include/odp/api/classification.h >>> +++ b/include/odp/api/classification.h >>> @@ -48,6 +48,18 @@ extern "C" { >>> */ >>> >>> /** >>> + * @def ODP_PMR_INVAL >>> + * Invalid odp_pmr_t value. >>> + * This value is returned from odp_pmr_create_match() and >>> + * odp_pmr_create_range() functions on failure. >>> + */ >>> + >>> +/** >>> + * @def ODP_PMR_SET_INVAL >>> + * Invalid odp_pmr_set_t value. >>> + */ >>> + >>> +/** >>> * Class-of-service packet drop policies >>> */ >>> typedef enum odp_cos_drop { >>> -- >>> 2.0.1.472.g6f92e5f >>> >>> >>> _______________________________________________ >>> lng-odp mailing list >>> lng-odp@lists.linaro.org >>> http://lists.linaro.org/mailman/listinfo/lng-odp >> > _______________________________________________ > lng-odp mailing list > lng-odp@lists.linaro.org > http://lists.linaro.org/mailman/listinfo/lng-odp
diff --git a/include/odp/api/classification.h b/include/odp/api/classification.h index 8758fb5..7db3645 100644 --- a/include/odp/api/classification.h +++ b/include/odp/api/classification.h @@ -48,6 +48,18 @@ extern "C" { */ /** + * @def ODP_PMR_INVAL + * Invalid odp_pmr_t value. + * This value is returned from odp_pmr_create_match() and + * odp_pmr_create_range() functions on failure. + */ + +/** + * @def ODP_PMR_SET_INVAL + * Invalid odp_pmr_set_t value. + */ + +/** * Class-of-service packet drop policies */ typedef enum odp_cos_drop {